Bug 47122 - Hang when creating new iOS project from template
Summary: Hang when creating new iOS project from template
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- major
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-11-16 18:27 UTC by Ben Beckley
Modified: 2017-05-31 18:46 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Xamarin Logs + Activity Log (20.96 KB, application/x-zip-compressed)
2016-12-01 18:12 UTC, Ben Beckley

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ben Beckley 2016-11-16 18:27:44 UTC
If I open VS, and then immediately try to create an iOS Class Library template - it fails. This also happens with numerous other iOS templates. Although, if I go to Tools>Xamarin>Options or go to Help>Xamarin Logs (a workflow that touches Xamarin bits, I am assuming), then I can create a template without issue. This is happening in (cycle9/2c75d6d) and (cycle8/47830f6).

Now, I have a lingering suspicion that this may be the result of a bad install, or environment specific issue as I have been experiencing odd behavior such as Bug 47010 on the same machine.
Comment 1 Ben Beckley 2016-12-01 18:12:08 UTC
Created attachment 18742 [details]
Xamarin Logs + Activity Log

Changed the summary to better reflect the broader reach of this bug. Adding logs as well.

env: https://gist.github.com/BenBeckley/2822409f8433e3e8df04e46e77e71c11
Comment 2 Ben Beckley 2016-12-13 22:26:39 UTC
So, I am encountering this again while using (cycle8/8681419) in VS2015 on the same machine as in the description.

I had completely uninstalled all VS versions (VS2013, VS2015, and VS2017) and reinstalled only VS2015. Things worked nicely for a while. Today I installed VS2013 and things were going well until I ran into this again. Not sure if there is any significance to that though, and don't want to chase after a red herring.

env info: https://gist.github.com/BenBeckley/f29ce024ca2d76a01a6801fcacf6864e
Comment 3 vga 2016-12-23 01:42:07 UTC
I took a look at the activity logs and the Xamarin logs and they don't contain any errors related to Xamarin.

If I'm getting this right, what you are experiencing is a hang of VS, in which case what we would really need to better diagnose this is a dump with full heap of the devenv.exe process.

If you can repro this, please send me the dump and I'll take another look.
Comment 4 Jose Gallardo 2017-05-31 18:46:49 UTC
Hey Ben,

I'm resolving the issue as not_reproducible.
But please feel free to reopen if you do still have a repro and can share the requested info.