Bug 47065 - UICollectionViewController: Cells rendering in variable/inconsistent sizes
Summary: UICollectionViewController: Cells rendering in variable/inconsistent sizes
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: XI 10.2 (iOS 10.1)
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: marcelo.perretta
Depends on:
Reported: 2016-11-15 22:10 UTC by Ashley Gazich [MSFT]
Modified: 2017-03-07 16:36 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Test case & screenshots (735.61 KB, application/zip)
2016-11-15 22:10 UTC, Ashley Gazich [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ashley Gazich [MSFT] 2016-11-15 22:10:26 UTC
Created attachment 18478 [details]
Test case & screenshots

### Summary

Customer reports that UICollectionViewController does not work as expected with Xamarin.iOS current Stable.

> The last working version was the Xamarin iOS xamarin.ios- All packages after that, does’t work or show[s] this problem.
> I used your ios-samples-master. SimpleCollectionView.
> If I scroll fast down and up, multiple times, the visible cells after scrolling are not well calculated or rendered. [I] don’t know where is the problem.
> I checked this on my physical iPad and also in the simulator. no differences. both devices have the iOS 10 Version.

### Expected results
Cells are uniform size after scrolling

### Actual results
Cell size is inconsistent, with some intermittently 2x-3x larger than others and/or missing image.
Downgrading from Xamarin.iOS to Xamarin.iOS did not seem to help.

iPad Air & iPad Retina simulators (both iOS 10.1) with XI appear to work OK
iPad Air 2 simulator (iOS 10.1, iOS 9.2) & iPad mini 2 (iOS 10.1) with XI exhibit issue
Simulators running iOS 9.2 or 10.1 with latest Stable exhibit issue

### Customer version info

Version 6.1 (build 5441)
Installation UUID: 7136a4f6-d849-412f-afa0-1befcfb73922
Mono 4.6.1 (mono-4.6.0-branch-c8sr0/ef43c15) (64-bit)
GTK+ 2.24.23 (Raleigh theme)
Package version: 406010005


Speicherort: /Applications/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

Version: (Xamarin Business)

Android SDK: /Users/svenreissenweber/Library/Developer/Xamarin/android-sdk-macosx
Unterstützte Android-Versionen:
4.0.3 (API-Ebene 15)
4.4 (API-Ebene 19)
4.4.87 (API-Ebene 20)
5.0 (API-Ebene 21)
6.0 (API-Ebene 23)
Version der SDK-Tools: 25.1.2
Version der SDK-Plattformtools: 24.0.0
Version der SDK-Buildtools: 23.0.2

Java SDK: /usr
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)
Android Designer EPL-Code ist hier verfügbar:

Xamarin Android Player
Version: 0.6.5
Speicherort: /Applications/Xamarin Android Player.app

Apple Developer Tools
Xcode 8.0 (11246)
Build 8A218a

Version: (Xamarin Business)
Hash: 39ebb77
Branch: cycle7
Build date: 2016-06-01 21:23:15-0400

Version: (Xamarin Business)

Build Information
Release ID: 601005441
Git revision: 68292d1ab289911c815ddc715dd7cc29a9752f9f
Build date: 2016-09-09 04:43:23-04
Xamarin addins: ed25d008672663eeb9db55f1ccecb3c24d2fd3b2
Build lane: monodevelop-lion-cycle8

Operating System
Mac OS X 10.12.1
Darwin Ian.local 16.1.0 Darwin Kernel Version 16.1.0
Comment 1 Alex Soto [MSFT] 2016-11-18 06:41:01 UTC
I can reproduce this issue but going to an early version of Xamarin.iOS like 9.8 does not seem to help which suggest this is likely an issue with the sample
Comment 2 Sven Reissenweber 2016-11-23 07:46:02 UTC
What means that? Is the problem my test case? 

What should I do? There is no solution, and I need one. Because we are not able to release.

Comment 4 Sven Reissenweber 2016-11-30 15:03:38 UTC
thanks for the support, 

i found the problem alone
Comment 5 Oleg Demchenko 2017-01-31 21:11:05 UTC
Hello @Sven,

Was it a problem in Xamarin sample? It seems like several people tried to reproduce this issue but no luck.
Comment 6 Vincent Dondain [MSFT] 2017-03-07 16:36:28 UTC
We have not received the requested information. Seems the issue is solved so I'm closing this bug.