Bug 46178 - NRE While starting the Designer agent
Summary: NRE While starting the Designer agent
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 4.4.0 (C10)
Assignee: Bugzilla
Depends on:
Reported: 2016-10-31 05:29 UTC by David Strickland
Modified: 2017-01-02 14:05 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

IDE Log File (16.12 KB, text/plain)
2016-10-31 05:30 UTC, David Strickland
SVCLog (46.58 KB, text/plain)
2016-10-31 05:31 UTC, David Strickland

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description David Strickland 2016-10-31 05:29:19 UTC
Upgraded to the latest version of Xamarin Visual Studio 3 days ago. After upgrading I could no longer attach to my Compiler agent. This happens fairly often after an upgrade and I in the past just upgrade XCode to resolve it however upgrading XCode did not resolved it. I uninstalled and reinstall XCode and still no joy.

I have VS 2015 running on a PC physically cabled to a ADSL Router. 
I am running my agent on a Mac-Mini with the latest update of XCode version 8.

The core error is
Xamarin.Messaging.Exceptions.MessagingException: Object reference not set to an instance of an object. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at Renci.SshNet.Session.Connect()
   at Renci.SshNet.BaseClient.Connect()
   at Xamarin.Messaging.Client.Ssh.SshCommandRunner.ValidateConnection()
   at Xamarin.Messaging.Client.Ssh.SshCommandRunner.<ExecuteCommandAsync>d__6.MoveNext()
Comment 1 David Strickland 2016-10-31 05:30:47 UTC
Created attachment 18269 [details]
IDE Log File
Comment 2 David Strickland 2016-10-31 05:31:13 UTC
Created attachment 18270 [details]
Comment 3 David Strickland 2016-10-31 05:35:08 UTC
Not Sure if its related but looking over the Service Log I'm seeing.

<Execution ProcessName="devenv" ProcessID="6704" ThreadID="53" /><Channel/><Computer>DESKTOP-IOH29LU</Computer></System><ApplicationData>monodroid: error XA9000: This version was released after your subscription expired (10/10/2016 9:13:39 AM).&#xD;&#xA;</ApplicationData></E2ETraceEvent><E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent"><System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system"><EventID>0</EventID><Type>3</Type><SubType Name="Error">0</SubType><Level>2</Level><TimeCreated SystemTime="2016-10-31T04:55:36.0355693Z" /><Source Name="Xamarin.VisualStudio.ActivationManager" /><Correlation ActivityID="{0445012c-ea86-4096-b546-90266299c9f0}" />

My old Xamarin Sub Expired 20 days ago. I switched over to the PrePackaged VS License and everything worked fine until the Xamarin IDE Update for VS that went out the end of last week.
Comment 4 David Strickland 2016-10-31 09:13:11 UTC
Started a new IOS project and tried to compile and got:
The installed Xamarin.iOS (version 10.0) on the Mac Mac-mini.local ( is not compatible with the local Xamarin.iOS 10.2.

Assuming it is likely the cause or contributing to the NRE Im Updating Xamarin Studio on the Mac
Comment 5 David Strickland 2016-10-31 11:25:51 UTC
Looks like updating Xamarin on the Mac resolved the issue. Presumably there is a bug with the Version checking. 

On my existing application either the Version check didnt happen or gave a false positive but in the new app the version check rightly identified a version error between my PC and my Mac.

Didnt close this as the bug does still exist even if the work around is moderately obvious.
Comment 6 Timothy Risi 2016-11-01 18:15:15 UTC
This looks like it's likely actually an issue with the Visual Studio extensions as opposed to Xamarin.iOS itself.  For the visual studio team: should we have a different error message if the only problem was version mismatch?
Comment 7 mag@xamarin.com 2016-12-22 19:23:11 UTC
Moving to cycle10 to provide a proper solution
Comment 8 mag@xamarin.com 2017-01-02 14:05:26 UTC
The expected behaviour when the Xamarin iOS versions doesn't match, is to not let VS to connect to the Mac when the Windows version is higher than the Mac version. Also, if Windows version is minor than Mac version, only a warning is displayed.

That said, version mismatch checks and messages have been improved in the past days. 

The changes will be available in the next release (cycle9sr1 or cycle10).
For the QA team, please test it based on master branch from commit de00b2c42b70167bfecd0b8adbcd5f5d99f0bd00