Bug 45804 - Type universe cannot resolve assembly: Xamarin.Forms.Platform.WP8
Summary: Type universe cannot resolve assembly: Xamarin.Forms.Platform.WP8
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-10-21 23:28 UTC by John Doe
Modified: 2017-04-30 13:26 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Test case for this issue (111.18 KB, application/zip)
2017-03-22 17:12 UTC, Daryl

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description John Doe 2016-10-21 23:28:38 UTC
When compiling with Xamarin Forms and XLabs Forms for a Monogame UWP Project the following error shows:

Severity	Code	Description	Project	File	Line	Suppression State
Error		Type universe cannot resolve assembly: Xamarin.Forms.Platform.WP8, Version=, Culture=neutral, PublicKeyToken=null.	Game	C:\Program Files (x86)\MSBuild\Microsoft\WindowsXaml\v14.0\8.2\Microsoft.Windows.UI.Xaml.Common.targets	352	

Xamarin.Forms Version:
XLabs.Forms Version: 2.0.5782

I cannot update XLab Forms to a newer pre-release because of the Error.
Comment 1 Samantha Houts [MSFT] 2017-02-01 19:22:08 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. 

If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction. 

For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d  

Warm regards, 
Xamarin Forms Team
Comment 2 Daryl 2017-03-22 16:52:49 UTC
I have added a windows universal project to my app today and I get this issue.

Using the same version of xlabs - but with the latest stable build of Xamarin Forms,

This is a blocking issue for me, as I cannot build the app currently.

I have created a test project with just the bare minimum as content. So just Xamarin forms, the .net core package for windows universal, and xlabs.

I have not added any of the requirements for a uwp app in xamarin, such as the changes to app.xaml etc. (But I have in my original project that this affects and there is no difference.)

I have also tried upgrading to the latest prerelease version of xamarin forms to see if that helps, and it doesn't. Same issue.

The project is attached.

Please can this be fixed as soon as possible.
Comment 3 Daryl 2017-03-22 17:12:54 UTC
Created attachment 20687 [details]
Test case for this issue

This is the described test case, cleaned down as much as possible. Should still reproduce this issue.
Comment 4 Torsten 2017-03-27 08:54:40 UTC
is this resolved?

have the same error...
Comment 5 Shimmy 2017-04-30 13:26:55 UTC
Same here.