Bug 45352 - Failed to install app, Calabash, UITest
Summary: Failed to install app, Calabash, UITest
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: XI 10.0 (iOS10)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
Depends on:
Reported: 2016-10-13 10:51 UTC by Chris Myhill
Modified: 2016-10-18 16:27 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Chris Myhill 2016-10-13 10:51:52 UTC
Every time I run my ui test locally on a IOS 10 and 9.3 simulator I am getting the following exception;


Failed to install app /xx/xxx.app

ExitCode: 7
Unrecognized flag: xx/xx.app

    -u,--update-app <true-or-false> [OPTIONAL]  When true, will reinstall the app if the device contains an older version than the bundle specified DEFAULT=1
    -c,--codesign-identity  <codesign-identity> [OPTIONAL]  Identity used to codesign app bundle [device only]  DEFAULT=
    -a,--app-bundle <path/to/app-bundle.app>    Path .app bundle (for .ipas, unzip and look inside of 'Payload')
    -d,--device-id  <device-identifier> iOS Simulator GUID or 40-digit physical device ID
Xamarin.UITest 2.0.0
Xamarin.TestCloud.Agent 0.20.3
XCode 8.0
Xamarin IDE 6.1 (build 5441)

Before XCode 8.0 and Xamarin 6.1 everything worked fine.

Any help much appreciated.


Stack Trace:

at Xamarin.UITest.iOS.iOSAppLauncher.LaunchAppLocal (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Http.HttpClient httpClient, System.Boolean clearAppData) [0x001fd] in :0 
at Xamarin.UITest.iOS.iOSAppLauncher.LaunchApp (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Http.HttpClient httpClient, Xamarin.UITest.TestCloud.TestCloudiOSAppConfiguration testCloudAppConfiguration, Xamarin.UITest.Shared.Http.HttpClient testCloudWsClient, Xamarin.UITest.Shared.Http.HttpClient xtcServicesClient, System.Boolean testCloudUseDeviceAgent) [0x0007a] in :0 
at Xamarin.UITest.iOS.iOSApp..ctor (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration) [0x00302] in :0 
at Xamarin.UITest.Configuration.iOSAppConfigurator.StartApp (Xamarin.UITest.Configuration.AppDataMode appDataMode) [0x00017] in :0 
at XXX.Setup () [0x000d5] in /xxxx/xx.cs:37
Comment 1 Alex Soto [MSFT] 2016-10-18 13:10:13 UTC
Hello Chris

I reached the team and they suggested me to try this pre-release package available here


To see if this solves your issue, in the case it still does not work please send us the  logs shown in the “Output” tab of the “Test Results” pad in XS.

Comment 2 Chris Myhill 2016-10-18 13:16:11 UTC
Thanks for getting back to me sorry for not closing this earlier.  My issue was related to the bug that, if the path to the IPA contains a space it will not deploy.  I removed all spaces from my path to the ipa.  All was fixed.
Comment 3 Chris Myhill 2016-10-18 13:18:25 UTC
My issue was resolved by removing all spaces in the path to my ipa.  This is a know bug  see - http://forums.xamarin.com/discussion/comment/227621
Comment 4 Alex Soto [MSFT] 2016-10-18 16:27:28 UTC
Awesome, glad you could get rid of the issue. Thanks for reaching us!