Bug 45091 - Bulding for App Store with two Developer Accounts
Summary: Bulding for App Store with two Developer Accounts
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 4.3.1 (C9SR1)
Assignee: Bugzilla
Depends on:
Reported: 2016-10-06 00:54 UTC by Victor Arce
Modified: 2017-01-09 10:21 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Victor Arce 2016-10-06 00:54:35 UTC

I've experienced this problem and I believe its a bug.

First, one of my customers who I created an app for, they sent me their app developer credentials, so I added a their account to my current XCode (under behaviours->accounts)  So in the end, I had two accounts (mine and my customers). I created all the neccesary Certificates, provisioning files, etc. for my mac, using their credentials.

So, when building the final release, I got two different errors, one is error : Tool exited with code: 1.   And I can't recall the second one.

Then i tried repeatedly cleaning/building/restarting and couldn't get it to work, and it was working because a few minutes before, by mistake I compiled with one of my own App Store provisioning files with no problem. (This is before adding the second account)

So, up to this point the only 'different' thing was that I had two apple dev accounts. I deleted my own, leaving only my customers, in Xcode and it worked.

BTW I'm using the latests versions on everything: VS, Xamarin.iOS, Forms, etc. as of 10-05-2016

Just wanted you to know my experience.

Hope it helps
Comment 1 Timothy Risi 2016-10-07 18:29:08 UTC
Hello Victor,

In Xamarin Studio, was the project set to automatically pick the signing identity and/or the provisioning profile, or were they set to a specific account/profile?
Comment 2 Manuel de la Peña [MSFT] 2016-10-13 12:31:44 UTC

Can you please provide the requested information so that we can look into the issue?
Comment 3 Victor Arce 2016-10-13 14:28:40 UTC
Hi guys, 

Regarding Timothy's question, there where set to automatic.

I wanna work at Xamarin! =)
Comment 4 Victor Arce 2016-10-13 14:46:22 UTC
Hi again, Timothy: I'm using Visual Studio 2015 (Not XS)
Comment 5 Manuel de la Peña [MSFT] 2016-10-14 08:27:25 UTC
I would consider this to be a VS bug, will assign to them to triage.
Comment 6 Jose Gallardo 2016-12-23 18:44:18 UTC
Hi Victor,

Are you still facing this issue?
If that's the case, can you please provide the following environment information:

Go to the menu "Help - About Microsoft Visual Studio" and press "Copy Info". Please paste that info into a Bugzilla comment.

We'll investigate, but I would really appreciate if you can share with us the requested information.

Comment 7 Manuel de la Peña [MSFT] 2017-01-09 10:21:50 UTC

We have not received the requested information. If you are still 
experiencing this issue please provide all the requested information 
and re-open the bug report.