Bug 44799 - MT3001 error when building a project that includes the UrbanAirship DLLs
Summary: MT3001 error when building a project that includes the UrbanAirship DLLs
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler ()
Version: XI 10.0 (iOS10)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
Depends on:
Reported: 2016-09-27 21:22 UTC by Adam van den Hoven
Modified: 2016-12-08 01:58 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Adam van den Hoven 2016-09-27 21:22:59 UTC
When I build a project that includes the UrbanAirship DLLs, I get an AOT error during compile:  

Projects/BugTestMT3001/BugTestMT3001/MTOUCH: Error MT3001: Could not AOT the assembly 'Projects/BugTestMT3001/BugTestMT3001/obj/iPhone/Debug/build-ipad5.3-10.0.2/mtouch-cache/Build/AirshipBindings.dll' (MT3001) (BugTestMT3001)

This project only includes the nuget and makes a call to Urban Airship's configuration method (without any configuration files, it is going to fail).

There is nothing sensitive in the project (the config is absent and not needed to demonstrate this error).
Comment 1 Adam van den Hoven 2016-09-29 02:27:14 UTC
I think this issue is more related to my own setup. After reporting this bug (because the docs I found said to report a bug when you encounter this problem) I went and started installing older versions of XS because it worked once. I went back to June it continued to fail so I reported it to the guys and Urban Airship (with the same project). They were able to build without AOT errors so I went and removed the references to Urban Airship from my real app, including commenting out all sorts of code, removed the bin and obj directories, did a build, added Urban Airship back in and the build worked. 

Not sure why the only thing I can think of is that it has to do with the fact that up until recently I've been using the VS plugin with VS2013 on Win10 to using XS on my Mac (windows is virtualized, not sure that would matter). I've had other problems that may have to do with this move. For example, with my Android app, I was getting native exceptions that would generate a stacktrace but recreating the project in the solution seems to have solved the problem (I'm not sure its 100% the solution because I haven't moved all the real code over yet, so maybe its something else not playing nice).
Comment 2 Vincent Dondain [MSFT] 2016-09-29 10:16:37 UTC
Hi, so I created a brand new iOS template, included the UrbanAirship nuget package and did not get any build error.

In order to help you we'd need the following things:

- The version of the urbanairship package.
- Your full build logs.
- Crash reports (if any).
- A test case (to reproduce) in the exact non working conditions (debug/release, what project options do you have, linker or not, etc...).
- All version informations.

The test case might help us get closer to your environment and actually get the same issue and the full build logs might give us clues on what could lead to this error.
Comment 3 Timothy Risi 2016-12-08 01:58:51 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!