Bug 44660 - Getting error when trying "Run in Test Cloud" - Unable to find the nunit.framework.dll in the assembly directory.
Summary: Getting error when trying "Run in Test Cloud" - Unable to find the nunit.fram...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Test Cloud ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-09-22 22:42 UTC by Ben Beckley
Modified: 2016-09-22 22:54 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ben Beckley 2016-09-22 22:42:24 UTC
I am unable to run an app on Test Cloud from a UITest project option menu. Here is the output:

Reproduction Steps:
1) Create a new Android app from template
2) Add an Android UITest project to the solution
3) Add a reference to the Android app to the UITest project
4) Add Internet permissions to the Android app
5) Deploy the Android app in release mode to generate the apk
6) Right-click the UITest project and select "Run in Test Cloud..."
7) Observe line in Test Cloud output stating
>Unable to find the nunit.framework.dll in the assembly directory.

I could very well be missing a step which is resulting in the behavior. But I ran the same project in the c7sr1 release build and it worked there. Then I went back to and I could run it in Test Cloud without issue.

Env info: https://gist.github.com/BenBeckley/3affc4116b61ea0ed687be84371d3816
Comment 1 Ben Beckley 2016-09-22 22:54:08 UTC
Didn't include the apk path in my test code. That was the problem.