Bug 44631 - Infinite Loading Designer View
Summary: Infinite Loading Designer View
Status: RESOLVED DUPLICATE of bug 44621
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 7.0 (C8)
Hardware: PC Windows
: --- critical
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-09-22 17:19 UTC by alexcons
Modified: 2016-10-07 17:46 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Xamain Log files (3.92 KB, application/x-zip-compressed)
2016-09-22 17:19 UTC, alexcons

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description alexcons 2016-09-22 17:19:06 UTC
# Steps to reproduce
1) Open any android Layout.
2) Switch to Source View.
3) Switch to the Designer View.
4) Repeat steps 2 and 3 one or two more times and when it tries to load the designer it will display an infinite loading bar which will now happen on all other layouts in the project.

# Expected behavior
It should continue to swtitch seemlessly between Source and Designer view

# Actual behavior
It will display an infinite loading bar which will now happen on all other layouts in the project.

# Supplemental info (logs, images, videos)

System.AggregateException: One or more errors occurred. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at Xamarin.VisualStudio.Android.Designer.MonoAndroidDesignerDocumentCache.Push(String filePath, AndroidDesignerDocumentCacheItem value) in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\Designer\MonoAndroidDesignerDocumentCache.cs:line 25
   at Xamarin.VisualStudio.Android.MonoAndroidDesignerPane.OpenViewCode() in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\Designer\MonoAndroidDesignerPane.cs:line 619
   at Xamarin.VisualStudio.Android.MonoAndroidDesignerPane.<OpenViewCodeAsync>b__66_0() in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\Designer\MonoAndroidDesignerPane.cs:line 612
   at System.Threading.Tasks.Task`1.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
   --- End of inner exception stack trace ---
---> (Inner Exception #0) System.NullReferenceException: Object reference not set to an instance of an object.

# Test environment (full version information)

Microsoft Visual Studio Professional 2013
Version 12.0.40629.00 Update 5
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Professional

.  .  .

Xamarin (c4382f5)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (0e59c36)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS (6c3fee4)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 alexcons 2016-09-22 17:19:56 UTC
Created attachment 17686 [details]
Xamain Log files
Comment 2 Jose Gallardo 2016-09-22 18:20:16 UTC
Hi Alex,

Thanks for the info!
It seems like this same issue has been already reported.
I'll mark this one as duplicate of 44621 to unify the information.
We'll investigate.

Thanks again!

*** This bug has been marked as a duplicate of bug 44621 ***
Comment 3 Sherif Mankarious 2016-10-04 16:29:11 UTC
Has this been resolved yet? If so, what patch or fix should I run to get that fixed?

N.B. When I try accessing 44621 I get a 'you are not authorized' message.
Comment 4 Ivan 2016-10-07 17:46:02 UTC
Same issue here. When i tried to downgrade xamarin.Android to 4.1.2 designer worked fine