Bug 44250 - Webview data binding not working in CarouselView
Summary: Webview data binding not working in CarouselView
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-09-13 14:37 UTC by kyle-hanish
Modified: 2017-06-19 16:37 UTC (History)
4 users (show)

Tags: WebView , CarouselView
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description kyle-hanish 2016-09-13 14:37:58 UTC
Currently when I put a webview in the data template for the new CarouselView control data binding will not correctly set the source. I only get a white screen. 

I know this was a previous issue when webviews were put into a list view template that may not have been checked when creating the new control? I believe they fixed that in 2.2. 

Here's some example code. 

class MyViewModel{
        public HtmlWebViewSource Source { get; set; }

<cv:CarouselView x:Name="cvImages" AbsoluteLayout.LayoutBounds="0,0,1,1" AbsoluteLayout.LayoutFlags="All" IsVisible="False">
            <WebView Source="{Binding Source}" Navigating="Browser_Navigating" HeightRequest="250" WidthRequest="250" />  


I've also tried this method, which resulted in the same white screen. 

        <HtmlWebViewSource Html="{Binding HtmlString}"/>
Comment 1 Rui Marinho 2017-01-04 16:52:43 UTC
Needs Info 

Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it.  

For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d  

Warm regards, 

Xamarin Forms Team
Comment 2 Chris Hardy [MSFT] 2017-06-19 16:37:37 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!