Bug 43699 - Could not install Xamarin
Summary: Could not install Xamarin
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-08-24 11:29 UTC by José Fabio Martinez Gonzalez
Modified: 2017-10-16 06:14 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Images that show the errors (217.27 KB, application/zip)
2016-08-24 11:29 UTC, José Fabio Martinez Gonzalez

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description José Fabio Martinez Gonzalez 2016-08-24 11:29:26 UTC
Created attachment 17193 [details]
Images that show the errors

I just updated to the newest beta version of Xamarin for Visual Studio. Since then I am unable to open my projects. When I go to the Xamarin options in Tools –> Options... –> Xamarin I see the text "An error occurred loading this property page".

My Android and iOS project tells me "This project is incompatible with the current edition of Visual Studio.

I got Visual Studio Professional 2015 Version 14.0.25425.01 Update 3.
My Xamarin version is (b9b610a).
My Xamarin.Android version is (f742154).
My Xamarin.iOS version is (9eca876).

I tried to reinstall Xamarin. The stable version works for me. Updating to the beta and I get the error described above.
Comment 1 José Fabio Martinez Gonzalez 2016-08-25 12:57:10 UTC
After some researching and reinstalling and repairing Visual Visual Professional 2015 Xamarin doesn't work for me anymore. Doesn't matter if stable, beta or whatever. I always get the described error above when I try to open the Xamarin iOS settings: "An error occurred loading this property page".

The last solution I had was to complete uninstall Visual Studio studio and then to install it again. Xamarin works now in stable and beta channel.
Comment 2 Ben Beckley 2016-08-25 17:19:24 UTC
Hello José,

I am sorry to hear that you had to go through and completely uninstall and reinstall Visual Studio to solve this problem. That can be a time consuming process. Also, thank you for taking the time to post and follow up on this bug report.

This looks similar to a known bug that is affecting Visual Studio extensions, and is not limited to Xamarin for Visual Studio. More information can be found in Bug 40781. In short and to the point, a workaround is to delete the ComponentCache files located at

I will be marking this as upstream based on the previous assessment. And again, my apologies that you had to go through the troubles of completely reinstalling Visual Studio.
Comment 3 José Fabio Martinez Gonzalez 2016-08-26 08:01:15 UTC
Hi Ben,

Thanks for your answer and sorry for the double bug report I did. Fortunately, I could use Xamarin Studio for Mac OS instead. Otherwise it would have been hard to explain to my boss that I couldn't work because my IDE is broken.

Thanks for your provided solution.
Comment 4 Devesh Mishra 2017-10-16 06:14:05 UTC

I am also getting the same error with Xamarin update (
I tried above mentioned solution. But it's not working.

Please help