Bug 43001 - Deadlock on project loading
Summary: Deadlock on project loading
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.2.0 (C8)
Hardware: PC Mac OS
: --- critical
Target Milestone: 4.2.0 (C8)
Assignee: Juan Marcelo Tondato
Depends on:
Reported: 2016-08-02 16:13 UTC by Jérémie Laval
Modified: 2016-08-09 13:36 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Comment 1 xamarin-release-manager 2016-08-04 19:52:08 UTC
Fixed in version (master)

Author: jmt
Commit: 260f9c698d273b56d05e9cf53b841edb4d031af9 (xamarin/XamarinVS)
Comment 2 xamarin-release-manager 2016-08-04 19:52:22 UTC
Fixed in version (cycle8)

Author: jmt
Commit: d5d0c909a596f05fe1b1eccdc49a8ed558dd4867 (xamarin/XamarinVS)
Comment 3 Jatin 2016-08-09 13:36:39 UTC
I tried to reproduce this issue with the build:
XVS (a02c54d)

But could not able to reproduce it successfully, as the deadlock condition is not appearing on opening android projects.

However, with the latest master build as well as the latest cycle 8 build, we are not encountering this behavior, as I did not observe any deadlock on project load, I have followed the below mentioned steps:

1. Open the XS
2. Open Android application
3. And then again opened another android application using: File >> Open
4. Repeated step 3 multiple times
5. Did not observe any deadlock as every-time the application opened successfully.

I have tried using VS also.

Below is the screencast for the same:

XS: http://www.screencast.com/t/JICyjvOwGyZ0
VS: http://www.screencast.com/t/uEqbOj5a3gLg

Please review the screencast provided above. Also let us know if any additional scenarios we need to cover for this. So that we can verify and close this issue.