Bug 4254 - Can't build project because of generated bad path to referenced project DLL
Summary: Can't build project because of generated bad path to referenced project DLL
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.9.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-04-05 06:53 UTC by Tony
Modified: 2012-04-30 00:00 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Tony 2012-04-05 06:53:04 UTC
Description of Problem:

Just upgraded to MonoDevelop 2.9.3 and now the solution will not build.

The iPhone project references a library project in the solution. When building, the error reported is

"Metadata file `...` could not be found (CS0006)."

The path shows that it is looking for the referenced DLL from the other project in the wrong location.

What it shows:

What it should be:

There is no `CloudClient.app` directory the debug directory. This solution built just prior to upgrading. There were no changes to the solution, either project, or source files. After upgrading, the solution fails to build with the error as described.

Steps to reproduce the problem:
1. Add a project reference to project in the solution.
2. Build

Actual Results:
Build fails with error because the referenced project dll can't be found.

"Metadata file `...` could not be found (CS0006)."

Expected Results:
Successful build.

How often does this happen? 
Every time.

Additional Information:
Tried clean all, rebuild all.
Comment 1 Eric Beisecker 2012-04-09 13:26:03 UTC
I believe that a fix for this can be found in the new Alpha Release of MonoDevelop. 

Comment 2 Tony 2012-04-30 00:00:45 UTC
Thanks, that worked.