Bug 42459 - can not find mod-mono-server and can not download xsp from the download page .
Summary: can not find mod-mono-server and can not download xsp from the download page .
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: 4.6.0 (C8)
Hardware: PC Windows
: Low normal
Target Milestone: Community
Assignee: Bugzilla
Depends on:
Reported: 2016-07-11 08:51 UTC by lei zhang
Modified: 2016-08-09 02:55 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 42459 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description lei zhang 2016-07-11 08:51:23 UTC
I know , I need to download the XSP component  from download page , but when goto download page , there is no link for xsp , I am not sure if there is something wrong with my PC,  or there is no download link for XSP now . 

I also tried mono-2.8, and found the XSP will installed after the installer finished. and then I can find mod-mono-server.

more details : 
using windows platform ,  for asp.net with .Net 2.0 apache 2.0.54, 

error log :
 [Mon Jul 11 15:21:32 2016] [error] Failed running '/usr/bin/mod-mono-server --address --port 2000 --nonstop --master (null) (null) (null) (null) (null) (null)'. Reason: Unknown error
Comment 1 lei zhang 2016-07-13 08:10:06 UTC
also tried 3.2.3,  it contains mod-mono-server too. 
I am not sure if we removed the xsp or just removed mod-mono-server .
Comment 2 Rodrigo Kumpera 2016-07-20 19:05:08 UTC
Mod mono is not available for download in that page, you can get it from your linux distro packages. No binaries for other platforms at this point.

Mono 3.2.3 is very old, please use a more recent one like 4.4.0.

Not sure what's the issue you have, can you elaborate what testing steps you took?
Comment 3 lei zhang 2016-08-09 02:55:51 UTC
Hi , Rodrigo,
I am using windows platform , so there will be no binary for windows platform any more ?  or some later there will be binary available for windows? 

test steps : 
 want to usinig mono work with apache support asp dot net .  now I have a mod_aspdotnet work with asp (this porject is too old ),  we want to upgrade the apache to some later version, but mod_aspdotnet just support dotnet V2. So  I want to using mono to instead mod_aspdotnet.