Bug 42323 - "LaunchScreen.nib does not exist" error when building for device
Summary: "LaunchScreen.nib does not exist" error when building for device
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 9.8 (tvOS / C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
Depends on:
Reported: 2016-07-01 15:35 UTC by Adam Hartley [MSFT]
Modified: 2017-03-08 16:48 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Adam Hartley [MSFT] 2016-07-01 15:35:21 UTC
When building for a device, rather than the simulator, the following error is occuring:

/Users/clarkin/ewu-larkinc/ESPMobile/iOS/ESPMobile.iOS.csproj (Build) ->
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets (_CopyResourcesToBundle target) ->

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : System.IO.FileNotFoundException: /Users/clarkin/ewu-larkinc/ESPMobile/iOS/obj/iPhone/Debug/build-iphone7.2-9.3.2/ibtool/LaunchScreen.nib does not exist
File name: '/Users/clarkin/ewu-larkinc/ESPMobile/iOS/obj/iPhone/Debug/build-iphone7.2-9.3.2/ibtool/LaunchScreen.nib'
  at System.IO.File.Copy (System.String sourceFileName, System.String destFileName, Boolean overwrite) <0x1a24c60 + 0x00333> in <filename unknown>:0 
  at Xamarin.MacDev.Tasks.SmartCopyTaskBase.CopyFile (System.String source, System.String target, System.String targetItemSpec) <0x4fd0370 + 0x000c7> in <filename unknown>:0 
  at Xamarin.MacDev.Tasks.SmartCopyTaskBase.Execute () <0x4fcfb38 + 0x002bf> in <filename unknown>:0 

## Notes

This is a Forms 2.3 project.

Full build log can be found here: 


Customer is on latest Stable (XS 6.0.1 XI
Comment 2 Alex Soto [MSFT] 2016-07-02 03:56:58 UTC
Hello Adam, could you provide a test case for this?
Comment 5 faceoffers28 2016-07-15 17:56:09 UTC
This seems similar to my issue. https://bugzilla.xamarin.com/show_bug.cgi?id=42474
Comment 6 faceoffers28 2016-07-15 20:20:04 UTC
This might help. Downgrading to Xamarin Studio 5.10.3 fixed the .Nib issue on my Mac. That issue must have been tied to Xamarin Studio. Now, the app builds and deploys.

Xamarin Studio: http://download.xamarin.com/studio/Mac/XamarinStudio-

Here is my condensed about.

Version 5.10.3 (build 51)
Mono 4.4.1 (mono-4.4.0-branch-c7sr0/4747417)
GTK+ 2.24.23 (Raleigh theme)

=== Apple Developer Tools ===

Xcode 7.3.1 (10188.1)
Build 7D1014

=== Xamarin.iOS ===

Version: (Visual Studio Enterprise)
Hash: 3cf8aae
Branch: c7sr0
Build date: 2016-06-20 16:09:58-0400

=== Operating System ===

Mac OS X 10.11.5
Darwin MyMacBook.local 15.5.0 Darwin Kernel Version 15.5.0
    Tue Apr 19 18:36:36 PDT 2016
    root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64
Comment 7 clarkin 2016-07-18 14:49:44 UTC
Sorry for the delay, but I was able to solve the issue by creating a set of generic launch images for the iOS devices we're targeting.
Comment 8 Adam Hartley [MSFT] 2016-07-26 10:07:16 UTC
Closing this report as answered, feel free to re-open if you are affected by this issue again.
Comment 9 relliott.bahia 2017-03-08 12:05:50 UTC
Im using Xamarin Studio Community version 6.2 (build 1821) and I just began to encounter this device build error. It seemed to be happening randomly for the past several days but I could always get past it by cleaning, or rebuild all but now Im stuck. I have reset set my git branch to known working code, restated my mac, restarted my device etc and Im stuck. Im currently working on an iOS APNS implementation and must dev test on my device.

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: System.IO.FileNotFoundException: /Users/relliott/dev/MVI/mobile-ios/iOSMVP/iOSMVP/obj/iPhone/Debug/device-builds/iphone9.4-10.2.1/ibtool-link/LaunchScreen.storyboardc/01J-lp-oVM-view-Ze5-6b-2t3.nib does not exist
File name: '/Users/relliott/dev/MVI/mobile-ios/iOSMVP/iOSMVP/obj/iPhone/Debug/device-builds/iphone9.4-10.2.1/ibtool-link/LaunchScreen.storyboardc/01J-lp-oVM-view-Ze5-6b-2t3.nib'
  at System.IO.File.Copy (System.String sourceFileName, System.String destFileName, System.Boolean overwrite) [0x000d1] in <f712f98eb8e445c8918edaf595bbe465>:0 
  at Xamarin.MacDev.Tasks.SmartCopyTaskBase.CopyFile (System.String source, System.String target, System.String targetItemSpec) [0x0002e] in <5947fc78067f45a79bdcff52e68f89ce>:0 
  at Xamarin.MacDev.Tasks.SmartCopyTaskBase.Execute () [0x00121] in <5947fc78067f45a79bdcff52e68f89ce>:
Comment 10 relliott.bahia 2017-03-08 12:09:25 UTC
Im using Xcode 8.2.1 (8C1002) and my Xamarin environment is as follows:

Xamarin Studio Community
Version 6.2 (build 1821)
Installation UUID: 69a7709f-c4ae-442f-94d9-e38d76ba36bf
	Mono 4.8.0 (mono-4.8.0-branch/e4a3cf3) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 408000495


'/Applications/Xamarin Profiler.app' not found

Version: (Xamarin Studio Community)
Android SDK: /Users/relliott/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)

SDK Tools Version: 25.1.2
SDK Platform Tools Version: 24.0.0
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:

Xamarin Android Player
Not Installed

Apple Developer Tools
Xcode 8.2.1 (11766.1)
Build 8C1002

Version: (Xamarin Studio Community)

Version: (Xamarin Studio Community)
Hash: 35d1ccd
Branch: cycle9
Build date: 2017-02-16 17:40:00-0500

Xamarin Inspector
Not Installed

Build Information
Release ID: 602001821
Git revision: d41b6e51f3fa46a1943f2e31a778d28a7c73d069
Build date: 2017-02-17 15:18:19-05
Xamarin addins: 1363a8d943bab7700c93a97474060b6734aa7f94
Build lane: monodevelop-lion-cycle9

Operating System
Mac OS X 10.12.3
Darwin Robbies-MacBook-Pro.local 16.4.0 Darwin Kernel Version 16.4.0
    Thu Dec 22 22:53:21 PST 2016
    root:xnu-3789.41.3~3/RELEASE_X86_64 x86_64
Comment 11 Brendan Zagaeski (Xamarin Team, assistant) 2017-03-08 16:48:54 UTC
@relliot, if you get a chance, I'd recommend filing a new bug report [1] for the symptom as you're seeing it.  That way you'll be the reporter of the bug and you'll be able to update the Status to "reopened" etc. and the new bug report can focus on the specifics of your exact environment and project.

[1] https://bugzilla.xamarin.com/newbug

If by chance you might have tried some quick experiments to chop down your project to just a few files (maybe just the problematic interface builder document) and would be able to attach that on the new bug report, that would be perfect.  (You can also optionally mark the bug as "Xamarin Team (Private Bug)" when filing it to restrict visibility to the Xamarin Team.)

Any other suspicions or information you might have about whether the problem is specific to _one_ interface builder document vs. a change in your development environment that affects _multiple_ different projects would be excellent [2].  Thanks in advance!

[2] https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/howto-file-bug/

(There's also a chance that another community member might have run into and solved something similar in the past, so on the off chance you haven't tried it yet, a quick look on the Forums and Stack Overflow could potentially yield something interesting.  See also https://developer.xamarin.com/guides/cross-platform/troubleshooting/support-options/.)