Bug 42092 - Xamarin Client component on Android doesn't work
Summary: Xamarin Client component on Android doesn't work
Status: NEW
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
Depends on:
Reported: 2016-06-22 19:19 UTC by Laszlo Zold
Modified: 2016-08-31 20:34 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 42092 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Laszlo Zold 2016-06-22 19:19:04 UTC
I have a problem with twilio client component (https://components.xamarin.com/view/twilio-client)

I downloaded it, opened the android sample project, tried to run it but the app throws an exception and terminates. I'm not really good at Android this is why I chose Xamarin, but what I found so far is that it throws this exception:

06-22 09:00:37.907: W/System.err(5010): java.lang.NoSuchMethodError: no non-static method "Lcom/twilio/client/impl/useragent/UserAgent;.getDNSAddress()   [Ljava/lang/String;"
06-22 09:00:37.907: W/System.err(5010):     at com.twilio.client.impl.useragent.UserAgent.init(Native Method)
06-22 09:00:37.907: W/System.err(5010):     at com.twilio.client.impl.CallControlManager.initialize(CallControlManager.java:208)
06-22 09:00:37.907: W/System.err(5010):     at com.twilio.client.impl.CallControlManager.getInstance(CallControlManager.java:131)
06-22 09:00:37.907: W/System.err(5010):     at com.twilio.client.impl.TwilioClientServiceImpl.initialize(TwilioClientServiceImpl.java:176)
06-22 09:00:37.907: W/System.err(5010):     at com.twilio.client.TwilioClientService.initServiceImpl(TwilioClientService.java:83)
06-22 09:00:37.907: W/System.err(5010):     at com.twilio.client.TwilioClientService.onCreate(TwilioClientService.java:49)
06-22 09:00:37.907: W/System.err(5010):     at android.app.ActivityThread.handleCreateService(ActivityThread.java:2877)
06-22 09:00:37.907: W/System.err(5010):     at android.app.ActivityThread.-wrap4(ActivityThread.java)
06-22 09:00:37.907: W/System.err(5010):     at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1427)
06-22 09:00:37.907: W/System.err(5010):     at android.os.Handler.dispatchMessage(Handler.java:102)
06-22 09:00:37.907: W/System.err(5010):     at android.os.Looper.loop(Looper.java:148)
06-22 09:00:37.907: W/System.err(5010):     at android.app.ActivityThread.main(ActivityThread.java:5417)
06-22 09:00:37.907: W/System.err(5010):     at java.lang.reflect.Method.invoke(Native Method)
06-22 09:00:37.907: W/System.err(5010):     at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)

I tried it with different emulators with different API levels, but I was not able to make it work.

Can you please have a look? Thanks, Laszlo
Comment 1 Bill Holmes 2016-08-31 20:34:31 UTC
This component is maintained by Twilio http://twilio.com/

This report needs to be filed with Twilio's support system.  I am just not sure what that is.

We have sent messages to our contact at Twilio.