Bug 41965 - After upgrading to, iOS builds fail with Failed to resolve "System.Void CoreGraphics.CGSize::.ctor
Summary: After upgrading to, iOS builds fail with Failed to resolve "System.V...
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-06-17 23:12 UTC by John Hardman
Modified: 2017-01-03 18:00 UTC (History)
8 users (show)

Tags: iOS build
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description John Hardman 2016-06-17 23:12:04 UTC
After upgrading to today, my iOS build fails with the following error (reported by VS2015 update 2):

C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(673,3): error : Failed to resolve "System.Void CoreGraphics.CGSize::.ctor(System.Single,System.Single)" reference from "Xamarin.iOS, Version=, Culture=neutral, PublicKeyToken=84e04ff9cfb79065"

This is stopping all iOS builds. Please prioritise accordingly
Comment 1 Paul DiPietro [MSFT] 2016-06-20 13:22:30 UTC
What build channels of VS/XS are you running on?
Comment 2 Toni L. 2016-06-28 07:48:18 UTC
Same error here receiving the same error after updating to

VS 2015 Update 2
tried it with following version.

Jenkins build server is complaining as well. Please fix this asap.
Comment 3 Toni L. 2016-06-28 07:58:26 UTC
by the way stable channel
Comment 4 Niels 2016-07-02 19:23:48 UTC
Same here trying to run the SampleBrowser.iOS app from Syncfusion.

VS 2013 and 2015
Comment 5 Avidan Chen 2016-07-10 13:59:38 UTC
This happens for us as well. Please fix it ASAP - we cannot build iOS on our continuous integration server at all.

Stable build, tried both Xamarin.iOS and latest version. On latest Xamarin.iOS version, when building with AppStore configuration, the build never finishes, also in our Jenkins machine. Hence the downgrade to Xamarin.iOS
Comment 6 Samantha Houts [MSFT] 2017-01-03 18:00:54 UTC
This should have been fixed with Thank you!