Bug 41870 - Bug on Entry Focus when Unfocused
Summary: Bug on Entry Focus when Unfocused
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.2.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-06-15 21:20 UTC by Danilo
Modified: 2016-06-20 16:13 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Danilo 2016-06-15 21:20:41 UTC
I need that when the Entry lose focus, the focus returns to the Entry (Lock the focus on an Entry). 

I did the following code:

myEntry.Unfocused += (object sender, FocusEventArgs e) => {
            if (!e.IsFocused)

It works, but the keyboard stops working. Don't write anything on keyboard.
Comment 1 Prashant Cholachagudda 2016-06-18 16:43:37 UTC

It looks similar to the bug #39792, what version of Xamarin.Forms are you using? Could you try using the latest vesion of Forms packages
Comment 2 Danilo 2016-06-18 16:47:16 UTC
[assembly: AssemblyFileVersion ("")]
[assembly: AssemblyProduct ("Xamarin.Forms")]
Ok, i will try
Comment 3 Danilo 2016-06-20 14:05:08 UTC
It worked. Updated to the latest.
Comment 4 Paul DiPietro [MSFT] 2016-06-20 16:13:47 UTC
I assume by "it worked" you are no longer experiencing this issue as I could not reproduce it with the latest stable version of Forms.