Bug 4131 - Updating from 4.0.4 to 4.0.6 using MD doesn't close updater window, exposes endless pop-up bug
Summary: Updating from 4.0.4 to 4.0.6 using MD doesn't close updater window, e...
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: 2.8 beta 3
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-03-28 14:42 UTC by PJ
Modified: 2012-04-27 12:29 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description PJ 2012-03-28 14:42:30 UTC
This issue seems to manifest only under this specific case:

Upgrading only MFA from MFA 4.0.4 (stable) to MFA 4.0.6 (beta) using MonoDevelop (beta).

Behavior: http://screencast.com/t/keFXXEBDyziw
Error pop-up: https://gist.github.com/2228730
kill -QUIT log: https://gist.github.com/2228757

When upgrading *only* MfA, the MD 'Updates are available for MonoDevelop" window does not close when the installer starts.

This allows you to select [Upgrade] again after the installer finishes.

This then throws two errors. Closing those errors and then selecting 'Check for Updates' again gets you into the state shown at the end of the screencast where closing the pop-up simply reopens a new one.

Then MonoDevelop must be force quit to get out of this.

This behavior is *not* exhibited when using the beta MonoDevelop ( to downgrade from 4.0.6 to 4.0.4

This behavior is *not* exhibited when using the stable MonoDevelop ( to upgrade from 4.0.4 to 4.0.6
Comment 1 Mikayla Hutchinson [MSFT] 2012-03-28 21:33:41 UTC
Fixed being able to install the same update again on master, investigating the other issues.
Comment 2 Mikayla Hutchinson [MSFT] 2012-03-28 23:01:21 UTC
I found a possible cause for the exceptions and fixed it too.
Comment 3 Mikayla Hutchinson [MSFT] 2012-04-27 12:29:29 UTC
Assuming my fixes worked, since it hasn't been reported again.