Bug 40751 - Xamarin Inspector is launched but it never ends loading
Summary: Xamarin Inspector is launched but it never ends loading
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Windows ()
Version: 0.8.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: inspectordev-discuss
Depends on:
Reported: 2016-04-28 07:45 UTC by Alejandro
Modified: 2016-05-11 07:29 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Inspector logs (4.57 KB, text/plain)
2016-04-28 07:45 UTC, Alejandro
Xamarin Inspector and Emulator (157.65 KB, image/png)
2016-05-09 07:21 UTC, Alejandro
Virtual Switches Hyper-V (35.43 KB, image/png)
2016-05-10 06:41 UTC, Alejandro

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alejandro 2016-04-28 07:45:25 UTC
Created attachment 15863 [details]
Inspector logs


Today I've downloaded Xamarin Inspector on Windows 8, I've installed correctly the app (at least I didn't have any error), I've launched Xamarin Inspector and I've chosen Ancroid as target platform.
The emulator has been launched and the Xamarin Inspector editor has started to load. However, the loading wheel never ends rotating and nothing is shown on the screen.
Besides, I've tried to open an existing workbook from Github and the result has been the same.
Comment 1 Sandy Armstrong [MSFT] 2016-05-02 15:28:29 UTC
What Android emulator are you using, and which device for that emulator?
Comment 2 Alejandro 2016-05-09 07:21:13 UTC
Created attachment 15942 [details]
Xamarin Inspector and Emulator
Comment 3 Alejandro 2016-05-09 07:24:25 UTC

I think that it is an emulator launched from Android Emulator for Visual Studio.

However, I've launched manually all the emulators that I have on Visual Studio but none of them matches the appearence of the emulator from Xamarin Inspector...

I've just attached an screenshot of the emulator and Xamarin Inspector.
Comment 4 Sandy Armstrong [MSFT] 2016-05-09 13:18:53 UTC
Yes, from your screenshot, that is the Visual Studio Android Emulator, which is the preferred emulator (the only other supported emulator right now is Xamarin Android Player).

Can you test and see if that emulator has internet access?

In my experience, the VS Android Emulator's network access gets messed up every time I change what network I'm on, at which point I have to follow this procedure to fix it:

1) close emulator
2) Open Hyper-V Manager
3) Under Actions, open Virtual Switch Manager...
4) Delete all virtual switches
5) Click OK
6) Launch VS Android Emulator. You will probably be prompted to recreate virtual network switch.
7) Test that VS Android Emulator's browser can access internet
Comment 5 Alejandro 2016-05-10 06:40:58 UTC

Yesterday I deleted all the virtual switches and I've restarted my emulator but I still have the same problem...
I've attached an screenshot of virtual switches status (sorry but it's in spanish...)
Comment 6 Alejandro 2016-05-10 06:41:26 UTC
Created attachment 15954 [details]
Virtual Switches Hyper-V
Comment 7 Sandy Armstrong [MSFT] 2016-05-10 12:58:38 UTC
Did you test to see if the VS Android Emulator's browser can access the internet?
Comment 8 Alejandro 2016-05-11 06:39:54 UTC
Yes, I tried it and it's not possible....
Comment 9 Sandy Armstrong [MSFT] 2016-05-11 07:11:08 UTC
Okay, if your emulator has no network access, then that is the issue.

If deleting/recreating the virtual switches is not working, you'll want to seek support from the VS Android Emulator team. Sorry I can't be more help.

I'm closing this bug for now, but feel free to reopen if you still have problems after you get your emulator fixed.
Comment 10 Alejandro 2016-05-11 07:29:53 UTC
Thanks for your help!