Bug 40693 - Keyboard white box maintains after switching views
Summary: Keyboard white box maintains after switching views
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-04-26 04:27 UTC by Cody Beyer (MSFT)
Modified: 2016-09-26 18:01 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Sample (59.83 KB, application/x-rar)
2016-04-26 04:27 UTC, Cody Beyer (MSFT)

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Cody Beyer (MSFT) 2016-04-26 04:27:36 UTC
Created attachment 15841 [details]

# Description

The following sample demonstrates an issue where once navigating to new view containing a text entry, pulling the keyboard up and the hitting the back button will cause a white box to appear at the resulting screen

# Sample


# Video


# Steps to Reproduce 

1. Downloads sample
2. Deploy to device
3. Tap “Click hear to push view”
4. Tap into entry cell
5. Hit back to navigate back

# Expected Results

View should not contain any artifacts

# Actual Results

White box appears

# Versions

=== Xamarin Studio Business ===

Version 6.0 (build 4968)
Installation UUID: 70640bf4-5398-4934-afed-9da3bfa3a4df
	Mono 4.4.0 (mono-4.4.0-branch/a3fabf1) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000122

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.iOS ===

Version: (Xamarin Business)
Hash: 977921b
Branch: cycle7
Build date: 2016-04-07 14:20:17-0400

=== Xamarin.Android ===

Version: (Xamarin Business)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 25.1.1
SDK Platform Tools Version: 23.1.0
SDK Build Tools Version: 23.0.3

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Version: (Xamarin Business)

=== Build Information ===

Release ID: 600004968
Git revision: ab7092ce63351276394f283e4f9c8646baf51fce
Build date: 2016-04-08 09:30:34-04
Xamarin addins: be0a0aef6ec8b075b4ba4690bd147d1e33c2abd7
Build lane: monodevelop-lion-cycle7

=== Operating System ===

Mac OS X 10.11.4
Darwin Cody-MBP.local 15.4.0 Darwin Kernel Version 15.4.0
	Fri Feb 26 22:08:05 PST 2016
	root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
Comment 2 Reza 2016-05-04 07:55:54 UTC
Please let me know what additional info I could provide.
Comment 3 Paul DiPietro [MSFT] 2016-05-04 14:23:27 UTC
Hi Reza,

I attempted to reproduce this on an S5 I have as well as a simulator and am unable to get the same result, it seems. Does this still occur on the latest stable for you? There's always a chance this is a device or version-specific issue.
Comment 4 Reza 2016-05-07 15:05:25 UTC
I don't think it is device specific as I have seen it occur on my HTC One too.  It is much harder to reproduce and using the HTC One, I am not sure if it still occurs in the latest stable.

With the Samsung I8190 Galaxy S III mini, I can reproduce reliably every time (just tried it again using the latest stable).

Additionally, the demo I sent was simplified to avoid confusion. Some devices may hide the issue due to the issue outlined here (which stops scrolling altogether) - (http://stackoverflow.com/questions/26835061/android-windowsoftinputmode-adjustresize-still-panning).  My actual solution had this workaround in place, which may explain why you could not reproduce?

Please let me know if I can be of any further assistance at all.

FYI - please find my version information below.  

Xamarin Studio Business
Version 5.10.3 (build 51)
Installation UUID: c9bb6008-0da7-4675-9a85-97889cfb2b70
	Microsoft .NET 4.0.30319.34014
	GTK+ 2.24.23 (MS-Windows theme)

Location: C:\Program Files (x86)\Xamarin\Profiler\XamarinProfiler.exe

Version: (Xamarin Business)
Android SDK: C:\Users\Reza\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1

SDK Platform Tools Version: 23.1

SDK Build Tools Version: 23.0.0

Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

Android Designer EPL code available here:

Xamarin Android Player
Not Installed

Build Information
Release ID: 510030051
Git revision: f3c0d982165f785772d125f02668370d929014fb
Build date: 2016-03-24 16:41:31-04
Xamarin addins: ee5cfd3ecb6b20de47c1d25efb9a9abc101e8ce7
Build lane: monodevelop-windows-cycle6-c6sr3

Operating System
Windows 6.3.9600.0 (64-bit)
Comment 5 Reza 2016-05-13 16:15:43 UTC
Hi - any further info I can provide?  

I noticed that my version of Xamarin.Android is 6.0 and Cody's was 6.1.
  - Am I mistaken in thinking that I already have the latest?
  - Could it be a fix that has already been put in place?

Please would somebody try it with the official production version and let me know if you would like me to upgrade via some other route and try?

My final suggestion is, could you please produce an APK file for me, and I will run it on my device.  
  -If it works on the device, I will need some update.  
  -If not, it could be some device/OS version specific issue.
Comment 6 Rui Marinho 2016-08-12 14:21:40 UTC
Hi Reza, i also tried to reproduce the issue using Api 6.0 , but i can't, can you upload a sample that  you are using, and what device info.

Comment 7 Paul DiPietro [MSFT] 2016-09-26 18:01:32 UTC
Closing this for now because it appears that the issue has presumably been fixed. If there happens to be a definitive reproduction on the latest stable or pre in the future, this can be reopened.