Bug 40495 - UWP ListView Grouping has blank jumplist, Header data bound to GroupShortNameBinding
Summary: UWP ListView Grouping has blank jumplist, Header data bound to GroupShortName...
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.5
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-04-18 21:57 UTC by Lee McPherson
Modified: 2018-04-27 18:08 UTC (History)
8 users (show)

Tags: ac, uwp, listview
Is this bug a regression?: ---
Last known good build:

Use this solution to reproduce the empty jumplist problem (278.33 KB, application/x-zip-compressed)
2017-05-21 09:35 UTC, zhaoquan2008

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 40495 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Lee McPherson 2016-04-18 21:57:03 UTC
According to the docs, GroupDisplayBinding should control what is displayed in the headers for a grouped ListView and GroupShortNameBinding will show what is in the JumpList.

On UWP, in the latest 2.1.0 and the latest pre-2.2, GroupDisplayBinding does nothing.  To have data in my grouped Headers, I have to bind to GroupShortNameBinding or customize my own GroupHeaderTemplate.  

In addition, tapping the header will initiate the jumplist view, but ultimately shows nothing.  I have to use the hardware backbutton or use WindowKey-Backspace to go back.
Comment 1 Rui Marinho 2016-05-11 16:03:28 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it. 

For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Here's the gist of the code i tried and that shows correctly 

Comment 2 zhaoquan2008 2017-05-21 09:10:51 UTC
I am facing this problem. My app displays nothing after I click on a group header. But I can't reproduce it in a clean project.
Comment 3 zhaoquan2008 2017-05-21 09:35:49 UTC
Created attachment 22330 [details]
Use this solution to reproduce the empty jumplist problem

I worked for 2 days to find out the problem.

1. Open the solution, run the UWP project.
2. You will see a button at the bottom. Click it, and a new data will be added to the list.
3. Click the header of the group title (the "A" letter). 

Expected: A page with an "A"
Actually: A blank page

It seems that the problem only happens when you add new data to a list. If the data are all prepared when the list is created, the problem will no occur.
Comment 4 zhaoquan2008 2017-05-30 02:24:58 UTC
Just to inform you that a reproduction has been made.
Comment 5 Rui Marinho 2017-06-20 14:44:50 UTC
Thanks, i able to reproduce
Comment 6 Marvin Dickhaus 2018-04-27 18:08:10 UTC
I experience the same behaviour.