Bug 40341 - ADB is closed incorrectly after debugging
Summary: ADB is closed incorrectly after debugging
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 6.0.99
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-04-13 12:33 UTC by erwin.wildenburg
Modified: 2016-04-26 08:23 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description erwin.wildenburg 2016-04-13 12:33:02 UTC
Device: Xiaomi Mi5
IDE: Visual Studio 2015 Update 2

Debugging only works once. I start debugging my app and it works fine. After I click close debugger the app is killed on my phone and Visual Studio returns to normal.
When I start the app again in debug mode the debugger crashes and the app stays on a white screen.

In task manager I can see multiple instances of adb.exe running which I can't kill. adb.exe doesn't give any response (not even error messages) if I run "adb kill-server" or "adb start server".

I have to close Visual Studio and then kill all adb.exe instances and then I can debug the app again (1 time, after that the same thing happens).
Comment 1 erwin.wildenburg 2016-04-26 08:23:50 UTC
The (out of the box) cable was broken...
Replaced it with a Belkin USB 3.1 cable and now it works.