Bug 40315 - Code completion does not work in code templates
Summary: Code completion does not work in code templates
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 6.0.0 (C7)
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: (C8)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2016-04-12 18:44 UTC by Colby Williams
Modified: 2016-06-13 18:49 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Colby Williams 2016-04-12 18:44:09 UTC
Code completion doesn't work in code templates.

To reproduce, type "if" and hit tab to trigger the if-statement code template, code completion doesn't work while populating the templates $expression$ argument.  This is the case with all code templates.

[version info](https://gist.github.com/colbylwilliams/214b99f8ab7d5d85fdbc9027da30f4e8)
Comment 1 Colby Williams 2016-04-15 15:53:17 UTC
To my knowledge, this has never worked in Xamarin Studio 6.0+
Comment 2 Mike Krüger 2016-05-26 09:42:49 UTC
fixed in 6.1.0.4360
Comment 3 Rajneesh Kumar 2016-06-06 16:48:54 UTC
I have checked this issue with the following Master build:
XamarinStudio-6.1.0.4412_e60c3cbe57725d4127e9102aba5354d980af810c

I observed that code completion is working properly. Please refer the screencast given below: http://www.screencast.com/t/aE2Gxl45x

Thanks..!
Comment 4 Rajneesh Kumar 2016-06-13 18:49:33 UTC
This issue is working fine with the master build, so as per comment 3 I am closing this issue.

Thanks..!