Bug 40261 - WCF can't listen on any ip
Summary: WCF can't listen on any ip
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies ()
Version: 4.2.0 (C6)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2016-04-10 14:35 UTC by Amnon Drori
Modified: 2016-07-31 16:32 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 40261 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Amnon Drori 2016-04-10 14:35:42 UTC
I am trying to make a wcf service listen on any interface.
The following code works on windows. When I run it on Mac I get the error detailed below.

var uri = string.Format("net.tcp://{0}", ListeningPort);

// Create host
_host = new ServiceHost(_this, new Uri(uri));

// Add service endpoint
_host.AddServiceEndpoint(typeof(IAutomationAgentOperation), new NetTcpBinding(SecurityMode.None, false), "");

Results in the following error:
Addresses (IPv4) and ::0 (IPv6) are unspecified addresses. You cannot use them as target address.
Parameter name: hostNameOrAddress

I also tried listening on hostname without success.
The server starts, and the 

Please advise.

* Last minute addition: configuring "localhost" instead of hostname seems to be working.