Bug 40248 - Mono on OS X does not search for a library without a "lib" prefix at the path of the executable
Summary: Mono on OS X does not search for a library without a "lib" prefix at the path...
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: Interop ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-04-08 19:25 UTC by Dimitar Dobrev
Modified: 2016-04-08 19:25 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 40248 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Dimitar Dobrev 2016-04-08 19:25:37 UTC
Let's have a native library without a "lib" prefix, for example, taken from a framework. A good example would be "QtGui" from Qt. Let's try to P/Invoke it. As you know, Mono's dynamic loader starts enumerating combinations by using different paths, prefixes and extensions until it finds the desired library. The problem is that a particular valid combination is never attempted. This is the combination full path to the executable + no prefix + lib name + no extension. In other words, this path:


is never tried, unlike:




or just:


This makes Mono unable to load the library and leads to crashes. It has to be worked around by deliberately setting a "lib" prefix to the name of the library.