Bug 39571 - [Gtk] Xamarin Studio is not responding when switch from open iOS designer to other selection window
Summary: [Gtk] Xamarin Studio is not responding when switch from open iOS designer to ...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-13 16:57 UTC by Vojtěch Mádr
Modified: 2016-05-02 05:49 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Studio Log (3.34 MB, text/plain)
2016-03-30 06:48 UTC, Vojtěch Mádr
Details
iOS designer log (1.66 MB, text/plain)
2016-03-30 06:48 UTC, Vojtěch Mádr
Details
Report generate to apple from MacOS (2.29 MB, application/pdf)
2016-04-25 11:18 UTC, Vojtěch Mádr
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Vojtěch Mádr 2016-03-13 16:57:17 UTC
My Mac is MacbookPRO 13 mid 2014, 8GB RAM, 2.6 intel core i5

=== Xamarin Studio ===

Version 5.10.3 (build 26)
Installation UUID: b0dbb9a5-1b93-4470-b17a-51d074628c2a
Runtime:
	Mono 4.2.3 (explicit/832de4b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402030004

=== Xamarin.Profiler ===

Version: 0.31.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 6.0.2.1 (Starter Edition)
Android SDK: /Users/madrvojt/Android/AndroidSDK
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1.0
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.iOS ===

Version: 9.4.2.27 (Business Edition)
Hash: 58ba2bc
Branch: master
Build date: 2016-03-03 09:05:19-0500

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 510030026
Git revision: ac9b7fcba9ee92ac30c8eb90f20c2228ce033efa
Build date: 2016-03-01 18:02:09-05
Xamarin addins: 633fde3bf405e3c402a51980976c431c204cf4f6
Build lane: monodevelop-lion-cycle6-c6sr2

=== Operating System ===

Mac OS X 10.11.3
Darwin Vojtech-MacBook-Pro.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 1 Alan McGovern 2016-03-27 06:54:25 UTC
When Xamarin Studio becomes non-responsive can you run the following diagnostics and then attach the log file?

1) In the Activity Monitor, see what's the process id (PID) of Xamarin Studio.
2) Open a terminal a run "kill -QUIT pid" replacing pid with the process id found for Xamarin Studio.
3) Attach the latest Ide.*.log file you'll find from selecting Help - Open Log Directory in Xamarin Studio.

That should help us diagnose the issue.
Comment 2 Vojtěch Mádr 2016-03-30 06:48:06 UTC
Created attachment 15552 [details]
Xamarin Studio Log
Comment 3 Vojtěch Mádr 2016-03-30 06:48:47 UTC
Created attachment 15553 [details]
iOS designer log
Comment 4 Vojtěch Mádr 2016-03-30 06:52:32 UTC
Hello, i added logs to attachment. I hope this will help you.
Comment 5 Alan McGovern 2016-03-30 12:30:41 UTC
From the stacktrace it looks like Xamarin Studio has triggered an unusual error in Gtk which caused so much data to be repeatedly sent to the logging mechanism that it has slowed down the IDE.

Is the problem triggered when you have the iOS designer open and then click on another open tab to switch to it? Or is it something else? Could you record a screencast of the exact steps you follow to trigger the issue if it's more complicated than that?
Comment 6 Vojtěch Mádr 2016-03-30 13:26:55 UTC
Hello,

i added two videos with error: 

http://www.screencast.com/t/tqG9f9I2o4
http://www.screencast.com/t/fTKYA6f4mu

My flow was:
I clicked from iOS designer tab to editor tab and app not responding.
I hope this will help you.
Comment 7 Vojtěch Mádr 2016-04-25 10:56:35 UTC
Hello! Is the video helpful for you or not?
Comment 8 Vojtěch Mádr 2016-04-25 11:18:28 UTC
Created attachment 15830 [details]
Report generate to apple from MacOS
Comment 9 Vojtěch Mádr 2016-05-02 05:49:15 UTC
Reinstalling XS a Xcode solve my problem! Thanks for help.