Bug 39536 - Can't upgrade XS ("requires MSBuild Tools 2013") even if MSBuild Tools 2015 is installed
Summary: Can't upgrade XS ("requires MSBuild Tools 2013") even if MSBuild Tools 2015 i...
Status: VERIFIED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Installer ()
Version: 6.0.0 (C7)
Hardware: PC Windows
: Normal normal
Target Milestone: (C7)
Assignee: Marius Ungureanu
URL:
: 39732 ()
Depends on:
Blocks:
 
Reported: 2016-03-11 04:37 UTC by Andres G. Aragoneses
Modified: 2016-03-17 19:29 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot of the error, and control panel showing installed programs (89.29 KB, image/png)
2016-03-11 04:38 UTC, Andres G. Aragoneses
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED ANSWERED

Description Andres G. Aragoneses 2016-03-11 04:37:03 UTC
Tried to upgrade my XamarinStudio 6 (build 4520 for Windows) to build 4761 in the Alpha channel, and I got an error saying "requires MSBuild Tools 2013" (see screenshot).

However, my system has MSBuild Tools 2015 (which I guess is newer version): see screenshot also.

PS: I guess this dependency was added as a fix for bug 35978.
Comment 1 Andres G. Aragoneses 2016-03-11 04:38:50 UTC
Created attachment 15360 [details]
screenshot of the error, and control panel showing installed programs
Comment 2 Lluis Sanchez 2016-03-11 09:44:33 UTC
I think both versions are required. Marius?
Comment 3 Marius Ungureanu 2016-03-11 10:22:28 UTC
Hey! Yes, both versions are required.
Comment 4 Marius Ungureanu 2016-03-17 19:29:53 UTC
*** Bug 39732 has been marked as a duplicate of this bug. ***