Bug 39357 - Wrong delete word modifier on Windows
Summary: Wrong delete word modifier on Windows
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: Trunk
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2016-03-04 11:08 UTC by Marius Ungureanu
Modified: 2016-03-16 21:31 UTC (History)
1 user (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marius Ungureanu 2016-03-04 11:08:54 UTC
Usually, when wanting to delete a whole word on Windows, you'd do ctrl+ delete/backspace. MonoDevelop forces you to use alt instead, which is wrong.
Comment 1 Mike Krüger 2016-03-08 15:08:22 UTC
I checked the OnKeyPressEvent in TextArea.cs that's the entry point into the editor keyboard chain.

On windows holding ctrl+backspace results in State == None. On OSX/Linux it works like expected. Seems to be a windows/gtk only issue.