Bug 39351 - XS saves annoying <WarningLevel>0</WarningLevel> tags in project files
Summary: XS saves annoying <WarningLevel>0</WarningLevel> tags in project files
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: Trunk
Hardware: PC Windows
: Normal normal
Target Milestone: (C7)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2016-03-04 04:28 UTC by Andres G. Aragoneses
Modified: 2016-05-19 15:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andres G. Aragoneses 2016-03-04 04:28:37 UTC
Trying XS 6.0 preview 4520.

Steps to reproduce:
1. Open some solution.
2. Right-click on the solution node, -> Options menu.
3. Save some setting about Code Formatting (for instance, convert tabs to spaces -> ON)

Expected results:
The .sln file should change.

Current results:
The .sln file changes, but also all the .csproj files, with these kind of changes:

@@ -40,10 +40,11 @@
     <DefineConstants>TRACE</DefineConstants>
     <Optimize>true</Optimize>
     <DebugType>pdbonly</DebugType>
     <PlatformTarget>AnyCPU</PlatformTarget>
     <ErrorReport>prompt</ErrorReport>
+    <WarningLevel>0</WarningLevel>
     <CodeAnalysisRuleSet>MinimumRecommendedRules.ruleset</CodeAnalysisRuleSet>
   </PropertyGroup>
   <ItemGroup>
     <Reference Include="ServiceStack.Common">
       <HintPath>..\packages\ServiceStack.Common.3.9.33\lib\net35\ServiceStack.Common.dll</HintPath>
Comment 1 Lluis Sanchez 2016-03-04 17:11:25 UTC
I can't reproduce. Can you attach a solution I can use to repro the issue?
Comment 2 Andres G. Aragoneses 2016-03-05 07:51:34 UTC
Tried to attach in private mode, but received "Sorry, but you are not allowed to (un)mark comments or attachments as private". Then I sent the file via email.
Comment 3 Lluis Sanchez 2016-03-07 10:20:17 UTC
I tried to reproduce the problem with the solution you sent. I see how some SpecificVersion properties are removed, but I still can't reproduce the WarningLevel issue.
Comment 4 Andres G. Aragoneses 2016-03-07 10:27:52 UTC
So weird! What version are you using? Maybe it's already fixed in master?
Or maybe you're not testing in Windows and it can only be reproduced in Windows?
I don't recall having any SpecificVersion changes.
Comment 5 Lluis Sanchez 2016-03-07 10:32:02 UTC
I tried with 4520 and master, on Mac. Maybe Windows is the problem. I'll try.
Comment 6 xamarin-release-manager 2016-03-09 09:45:00 UTC
Fixed in version 6.0.0.4765 (cycle7)

Author: David Karla??
Commit: 7d0e817311c453e7179003aabdfcb3251cdc47fa (mono/monodevelop)