Bug 39317 - tvOS: Unable to open existing app with Navigation Bars in the Interface Designer
Summary: tvOS: Unable to open existing app with Navigation Bars in the Interface Designer
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-03 13:51 UTC by Kevin Mullins
Modified: 2016-03-03 14:25 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Kevin Mullins 2016-03-03 13:51:08 UTC
Opening the Storyboard for an existing Xamarin.tvOS app that is using Navigation Bars created in Xcode's Interface Builder is resulting in a "There was a problem rendering this document." error message in the Interface Designer.

Please see:
 * Documentation - https://developer.xamarin.com/guides/ios/tvos/user-interface/navigation-bars/
 * Sample App - https://developer.xamarin.com/samples/monotouch/tvos/tvNavBars/
Comment 1 Alan McGovern 2016-03-03 14:25:26 UTC
This opens just fine with the latest master builds. If it does not work in either the latest wrench master builds or latest wrench c7 builds then let me know. Older versions of XS are unlikely to be patched ot support whatever the issue was