Bug 3931 - Release to iPhone fails with "Unexpected error - Please fill a bug report... (MT0000)
Summary: Release to iPhone fails with "Unexpected error - Please fill a bug report... ...
Status: RESOLVED DUPLICATE of bug 3559
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-03-16 09:56 UTC by Jim Goff
Modified: 2012-03-18 14:15 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jim Goff 2012-03-16 09:56:11 UTC
This is my first deployment to a device.
1)  My trivial app works on the simulator.
2) When I tried "Debug|iPhone", it put the app on the iPod and started it, but I    did not get the starting screen.
3) So I tried "Release|iPhone".  It builds correctly, but is unsuccessful in moving the app to the iPod (I had removed it after step #2).

I am reporting it because it says:

"Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com (MT0000)"

Unfortunately, it doesn't identify the error beyond "Unexpected error -"

So I cannot say more at this point.

Jim Goff
Comment 1 Sebastien Pouliot 2012-03-16 11:05:46 UTC
see comment #3 of bug #3559.

i.e. Xcode 4.3[.1] was installed and Xcode 4.2 was removed (or never
installed). You need to install the optional "Command Line Tools" to get a
complete installation.

*** This bug has been marked as a duplicate of bug 3559 ***
Comment 2 Jim Goff 2012-03-17 14:18:18 UTC
install the optional "Command Line Tools"...

For an Apple newbie, this is easier said than done.  I downloaded v4.3.1 from the Mac Store.  CLT was/is a separate download.  I've downloaded it a half-dozen times, but I get a check-sum error whenever I try to install it.  I doubt the download is corrupt, rather something is out-of-sync and the designer of the set-up process was too lazy to give a better error message.  Any advice would be greatly appreciated.
Comment 3 Sebastien Pouliot 2012-03-17 17:54:44 UTC
You can download the optional tools from within Xcode itself.
See this link for instructions: http://stackoverflow.com/q/9348718/220643
Comment 4 Jim Goff 2012-03-18 14:15:14 UTC
I solved my own problem by downloading the "Command Line Tools" directly from the developer's webpage.  The March version yielded a checksum error just like the download from within Xcode 4.3.1 did .  But I did succeed with the February version.  I don't know why things were out-of-sync.