Bug 39205 - View > Unit Testing does not focus the Unit Tests pad
Summary: View > Unit Testing does not focus the Unit Tests pad
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-29 15:26 UTC by Kyle White
Modified: 2016-04-05 15:49 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Kyle White 2016-02-29 15:26:04 UTC
Steps to reproduce:
1) Close the Unit Tests pad
2) In the menu, select View > Unit Testing

Expected: Unit Testing view is shown which includes the Unit Tests pad and Test Results pad
Actual: Unit Tests pad is not opened/focused, Test Results pad is not opened/focused

This is a regression from C6

Screencast: http://screencast.com/t/HEDJQWxa3pq8
About: https://gist.github.com/kdubau/e3e8e0779f444161a0ca
Comment 1 Mike Krüger 2016-03-01 07:43:55 UTC
Works for me - however the view layouts can be changed - so if you've hidden the pads they stay hidden. It's a user decision how the unit testing view look. 

By default the pads are there.
Comment 2 Kyle White 2016-03-03 03:23:05 UTC
The pad is not hidden, in fact you can see in my screencast that I have it open, and going to View > Unit Testing actually closes the pad.
Comment 3 Kyle White 2016-03-03 03:25:09 UTC
I have not changed the view layout either. Please let me know if there is a way to "reset" the layouts and I will confirm.
Comment 4 iain 2016-03-07 10:49:29 UTC
Kyle, you have the Unit Test pad open for the "Solution" layout, but it must be closed for the "Unit Testing" layout. I've tested this and got the same results as Mike. At some point you must have closed the Unit Test pad while you were in Unit Testing layout.

If you delete ~/Library/Preferences/XamarinStudio-6.0/EditingLayout.xml you'll get the default layouts again.
Comment 5 Kyle White 2016-04-05 15:49:12 UTC
Yep on a fresh machine it is working.