Bug 39037 - Problem with signing Xamarin.mac 2.7, the application will not boot
Summary: Problem with signing Xamarin.mac 2.7, the application will not boot
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Runtime ()
Version: 2.7.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Chris Hamons
Depends on:
Reported: 2016-02-23 11:07 UTC by Alain
Modified: 2016-03-08 10:48 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alain 2016-02-23 11:07:34 UTC

I installed version Xamarin Xamarin.MAC Studio 6 and 2.7.

Since I can no longer run my Xamarin.MAC application, there is a signature issue. I can cast it without signature.

With version 2.4, I had no problem. I tried to recreate a new certificate but still the same problem.

What should I do ?

Process:               TestWEBView [9660]
Path:                  /Users/USER/*/TestWEBView.app/Contents/MacOS/TestWEBView
Identifier:            medinect.offimed.be
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           TestWEBView [9660]
User ID:               501

Date/Time:             2016-02-23 12:05:09.106 +0100
OS Version:            Mac OS X 10.11.3 (15D21)
Report Version:        11
Anonymous UUID:        B4DD4C68-25A3-4699-D21C-4A2E8A5CDBFB

Sleep/Wake UUID:       40FC0C0F-5D21-418D-B567-8051F22695D1

Time Awake Since Boot: 51000 seconds
Time Since Wake:       4400 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (Code Signature Invalid)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

kernel messages:

VM Regions Near 0x7fff777fe0a8 (cr2):
    __LINKEDIT             00007fff62c33000-00007fff62c48000 [   84K] r--/rwx SM=COW  /usr/lib/dyld
--> Submap                 00007fff70000000-00007fff80000000 [256.0M] r--/rwx SM=PRV  process-only VM submap
    unused shlib __DATA    00007fff7665d000-00007fff7abc3000 [ 69.4M] rw-/rw- SM=COW  system shared lib __DATA not used by this process

Thread 0 Crashed:
0   dyld                          	0x00007fff62bc0000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x000000000000000d  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x00007fff50b27868
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
  rip: 0x00007fff62bc0000  rfl: 0x0000000000000201  cr2: 0x00007fff777fe0a8
Logical CPU:     0
Error Code:      0x020000f4
Trap Number:     133

Binary Images:
    0x7fff62bbf000 -     0x7fff62bf6007  dyld (???) <9D05FDF4-65CE-3B53-86D4-ABE1A5BF35F3> /usr/lib/dyld

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 29388
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=308K resident=0K(0%) swapped_out_or_unallocated=308K(100%)
Writable regions: Total=10.4M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=10.4M(100%)
                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Process Corpse Info               2048K        2 
STACK GUARD                       56.0M        2 
Stack                             8192K        2 
VM_ALLOCATE                          4K        2 
VM_ALLOCATE (reserved)             204K        2         reserved VM address space (unallocated)
__DATA                             240K        3 
__LINKEDIT                          84K        2 
__TEXT                             224K        2 
mapped file                       4832K        4 
shared memory                        8K        3 
===========                     =======  ======= 
TOTAL                             71.5M       14 
TOTAL, minus reserved VM space    71.3M       14
Comment 1 Chris Hamons 2016-02-23 21:29:27 UTC
EXC_CRASH (Code Signature Invalid) suggests there is a problem with the code signing of your applications.

Running codesign, with various argument may be useful in figuring out what is going on.

codesign --display --verbose=4 Foo.app

Bug reports, however, are not the best place for requesting general help troubleshooting an issue. 

They are for verified issues, such as this used to work with this version, now does not with this version, here is an example showing the problem at hand and it is very likely a bug.

http://support.xamarin.com is a great place for assistance if you have a business license from Xamarin. https://forums.xamarin.com/categories/mac is a good place to look for community assistance as well. 

In either case, once troubleshooting has finished, we can get a reproducible example showing the issue at hand and file another bug.
Comment 2 Alain 2016-02-24 09:24:14 UTC
Yes, but there is a problem with the version 2.7 as in 2.4, I have no problem signing.

I redid profiles again and it does not work with version 2.7.

When I handed version 2.4.1, everything works with the old and the new profile.

So for me, there is a problem with version 2.7.

This version is no longer available now on Alpha Channel.

Comment 3 Alain 2016-02-27 11:29:56 UTC
I reinstalled the Xamarin.MAC version 2.7 and I still have the same signature problem as I do not have that problem with the Xamarin.MAC version 2.4.1.

I performed the requested command and the app is signed:

MacBook-Pro-de-Alain: Release alainrogister $ codesign --display --verbose = 4 Medinect.app
Identify = medinect.offimed.be
Format = bundle with Mach-O thin (x86_64)
CodeDirectory v = 20200 28663 size = flags = 0x0 (none) hashes = 1424 + 5 = embedded rent
Type = sha1 hash size = 20
CDHash = dcbd423167ae250a5ce968236aac1b86b981a675
Signature size = 4332
= Authority Mac Developer: Alain Rogister (RBN59W663R)
Authority = Apple Worldwide Developer Relations Certification Authority
Authority Apple = Root CA
Signed Time = Feb 27. 2016 12:23:54
Info.plist entries = 19
TeamIdentifier = 2K978J5KVS
Sealed Resources version = 2 rules = 12 files = 801
Internal requirements count = 1 size = 180
MacBook-Pro-de-Alain: Release $ alainrogister

There really is a problem to be paid.

Comment 4 Alain 2016-03-08 10:48:16 UTC
I have installed Xamarin.MAC 2.8 and I don't have this problem.