Bug 38965 - When missing reference, the "Resolve" option is missing
Summary: When missing reference, the "Resolve" option is missing
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 6.0.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2016-02-20 15:42 UTC by Martin Stanek
Modified: 2016-02-29 05:20 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Source analysis is turned on (53.71 KB, image/png)
2016-02-20 16:05 UTC, Martin Stanek
Details
But the Resolve and even Fix option is missing (136.36 KB, image/png)
2016-02-20 16:06 UTC, Martin Stanek
Details
Resolving of the 'Console' static class issue. (44.42 KB, image/png)
2016-02-22 17:40 UTC, Martin Stanek
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Martin Stanek 2016-02-20 15:42:00 UTC
When missing reference, the "Resolve" option is missing. 

ie.:

The "ServerStoppingFailedEventArgs" is defined in the namespace "Awitec.Common.Net.iOS.EventsArgs".
But when used in "Awitec.Common.Net.iOS" the automatic "Resolve" option is missing, was present in the right-click context menu.

Thx, Martin
Comment 1 Mike Krüger 2016-02-20 15:43:50 UTC
That's now in the 'fix' menu.
(But ensure that source analysis is turned on)
Comment 2 Martin Stanek 2016-02-20 16:05:46 UTC
Created attachment 15110 [details]
Source analysis is turned on
Comment 3 Martin Stanek 2016-02-20 16:06:13 UTC
Created attachment 15111 [details]
But the Resolve and even Fix option is missing
Comment 4 Martin Stanek 2016-02-20 16:06:25 UTC
Hi Mike, thank You for looking at it.

It's not really big deal for me to set this stuff again. (I'm using something between pure VS and Java style). Although, I need sync this between 2-3 Macs I'm using for the development.

Can imagine that many people will be complaining.

And Yes, Roslyn is big thing, I know. Altogether with C#6 and tvOS and all that stuff. I can imagine why you are working at Saturday.

Thx, Martin
Comment 5 Martin Stanek 2016-02-20 16:08:27 UTC
Hi Mike,

I'm very sory, the previous comment belongs to the another window.

Anyway, as You can see from the screenshots, eventhough with the source analysis option on, I do not see the desired option :)

Thx, Martin
Comment 6 Mike Krüger 2016-02-20 17:50:57 UTC
Ok we'rer unning into a bug here. 

Can you reproduce it with a simple file like:

class Test
{
    static void Main(string[] args)
    {
        Console.WriteLine("Hello");
    }
}

Is it possible to resolve 'Console' ?
Comment 7 Martin Stanek 2016-02-22 17:40:06 UTC
Hi Mike,

sorry for the delay.
Nope. I can't :(

Thx, Martin
Comment 8 Martin Stanek 2016-02-22 17:40:46 UTC
Created attachment 15129 [details]
Resolving of the 'Console' static class issue.
Comment 9 Mike Krüger 2016-02-23 06:19:17 UTC
I can't see it in the screenshot : did you add the file to a project ? 

In stand alone files that won't work.
Comment 10 Martin Stanek 2016-02-24 09:52:12 UTC
Hi Mike,

yes I've crated the brand new project for this test.

Console app, Mac OS.

Regards, Martin
Comment 11 Mike Krüger 2016-02-24 10:14:52 UTC
Is there anything in the logs ? help->open log directory ? 
Maybe there was an internal error (The 'fix' menu is very basic - it should always work :/).
Comment 12 Mike Krüger 2016-02-29 05:20:00 UTC
Seems that the released version contains a bug in the options dialog.

Turn on underline errors in the text editor options. That fixes that.