Bug 3896 - Unit Test Pad fails to load test classes: NUnit.Core.RemoteTestRunner
Summary: Unit Test Pad fails to load test classes: NUnit.Core.RemoteTestRunner
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 2.8.6
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2012-03-14 09:56 UTC by Nelson
Modified: 2012-03-14 16:07 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Test Pad fails to load. Error: Could Not Load Type NUnit.Core.RemoteTestRunner (127.59 KB, image/png)
2012-03-14 09:56 UTC, Nelson

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Nelson 2012-03-14 09:56:08 UTC
Created attachment 1515 [details]
Test Pad fails to load. Error: Could Not Load Type NUnit.Core.RemoteTestRunner

I just upgraded to Ubuntu 11.04 and got the new Monodevelop with it. The Unit Test pad fails to load test classes. So I upgraded to version 2.8.6 (http://monodevelop.com/Download from there instead of Ubuntu repositories) but I still got the same error.

I'm running a 64bit machine and in prior versions this was working fine. Now not even the most simple test can be loaded.

I'm attaching a screenshot of what I get. It fails at NUnit.Core.RemoteTestRunner

I have several testing projects and this is a big issue for me. I never expected this to stop working.

I have tried uninstalling and reinstalling components. I have also tried changing the target platform and even the .Net target framework from 2.0 all the way to 4.0 and still nothing in any combination.

Let me know if you need any more info and just instruct me on how to get it to you.

Comment 1 Mike Krüger 2012-03-14 16:07:10 UTC
The problem is the nunit version 2.5.x isn't supported by that version of monodevelop. You should set the reference to the monodevelop bundled version.

I think 2.4.x - I suppose it has to do with a mono framework upgrade ?

We updated nunit to 2.6.0 lateley - therfore I close that one. If it's important you could try a build from src. That's the fastest solution.