Bug 38510 - Xamarin Studio SIGABRT crash on startup
Summary: Xamarin Studio SIGABRT crash on startup
Status: RESOLVED DUPLICATE of bug 32385
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 6.0.0 (C7)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-05 22:09 UTC by Kent Green [MSFT]
Modified: 2016-03-02 18:30 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 32385

Description Kent Green [MSFT] 2016-02-05 22:09:05 UTC
## Overview
From this desk case: 
https://kb.xamarin.com/agent/case/254989

Customer reports that Xamarin Studio Crashes on startup. They sent their logs and the Xamarin Studio cache here:
https://drive.google.com/open?id=0B73CQ8o0VkZ4OUd0bnlYRzdzbHc

I noted that their main info for the crash is in Xamarin Studio 6.0, which is in preview; though the Xamarin-Studio-5.0 logs seemed to indicate a crash as well.

## Version info (from logs)
Xamarin Studio 6.0 (build 3668)
Mono 4.3.0 (mono-4.3.1-branch/37d269c)
Mac OS X 10.10.5
GTK+ 2.24.23

## Observations
I noticed a stacktrace occurring shortly before the crash occurred. It is quite long so I've added them in a secret gist. One other thing I noticed is that they occurred shortly after processing some of the Xamarin Studio Addins. Based on this I had the customer try cleaning the Xamarin Studio cache, though it didn't seem to help. 

https://gist.github.com/King-of-Spades/6b3f2b88c97560e295ce
Comment 1 Lluis Sanchez 2016-03-02 18:30:31 UTC

*** This bug has been marked as a duplicate of bug 32385 ***