Bug 38225 - Can't edit file in 2 column editor
Summary: Can't edit file in 2 column editor
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 6.0.0 (C7)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2016-01-30 23:18 UTC by Darrell Booker
Modified: 2017-02-14 08:42 UTC (History)
3 users (show)

Tags: c7regression
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Darrell Booker 2016-01-30 23:18:52 UTC
Typing into a newly opened file in the right column of the 2 column editor does nothing.  I have to close then re-open the file.
Comment 1 Mike Krüger 2016-01-31 08:24:43 UTC
Does that happen every time ?

Can you reproduce it ? I would need a test case.
Comment 2 Darrell Booker 2016-02-01 12:33:29 UTC
Looks like its not confined to when using the 2 column editor. also happens with the normal editor. Im trying to isolate when it happens so I can provide a test case
Comment 3 Mike Krüger 2016-02-01 12:54:51 UTC
It may be related to source control - is the project you have under subversion or git control ?
Comment 4 Darrell Booker 2016-02-01 12:57:20 UTC
yes it is under git. but I don't have the issue in studio 5.
Comment 5 Mike Krüger 2016-02-01 12:58:58 UTC
@Marius: Can you help tracking that ?

@Darrell: Can you give us the log file when that happens ?
Comment 6 Marius Ungureanu 2016-02-09 10:34:12 UTC
I can't seem to reproduce this locally, will need a log file of a session that exposes this behavior.
Comment 9 Marius Ungureanu 2016-11-16 16:02:50 UTC
We no longer spew exceptions from version control to the Editor. In case this was the problem which made the editor not work, then this bug can be closed.
Comment 10 Marius Ungureanu 2017-02-14 08:42:34 UTC
Marking as resolved as per comment #9. The fix with version control leaking exceptions to the editor has been done.