Bug 38202 - [tvOS] When you first drag a tvOS control on the Designer, you can't edit the title.
Summary: [tvOS] When you first drag a tvOS control on the Designer, you can't edit the...
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2016-01-29 19:33 UTC by Kevin Mullins
Modified: 2016-02-18 10:59 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 38202 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Kevin Mullins 2016-01-29 19:33:29 UTC
In the iOS Designer for tvOS, if you drag a new UIButton onto the design surface and try to edit the title, the keystrokes aren't accepted and you cannot change the title. The title is highlighted in the Properties field, but keystrokes don't register.

If you unselect and reselect the button, you can edit the title.
Comment 1 Kevin Mullins 2016-01-29 19:34:45 UTC
This is happening for any new control, not just buttons.
Comment 2 Alan McGovern 2016-02-01 11:40:35 UTC
Can you show a screencast of the problem?
Comment 3 Kevin Mullins 2016-02-01 15:37:22 UTC
Alan,

Here is a video: https://youtu.be/8umrtqAwRQA

The first time I select the new buttons name, even though I'm typing trying to change the name, nothing happens. If I unselect and reselect the button THEN I can change the name.
Comment 4 Alan McGovern 2016-02-02 10:01:16 UTC
That screencast was perfect! I has tried exactly that but it worked fine for me.

Are you on Yosemite or El Capitan? And does this happen with the latest monodevelop/master builds? Can you also include Xamarin Studio and Mono version information?

This looks suspiciously like a bug we've been trying to figure out which randomly breaks the search field in the top right of xamarin studio, but this is slightly different in that you can recover from the breakage. I can't trigger it yet :(
Comment 5 Kevin Mullins 2016-02-02 12:51:45 UTC
Here's the Mac's info:

OS X El Capitan
Mac mini (late 2012)
Processor 2.3 GHz intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics Intel HD Graphics 4000 1536 MB


And My build Version:

Xamarin Studio
Version 6.0 (build 3878)
Installation UUID: fb9e0af8-25b0-4923-bf17-6c3b3ed20714
Runtime:
	Mono 4.3.0 (mono-4.3.1-branch/37d269c) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403002114

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.2 (9548)
Build 7C68

Xamarin.iOS
Version: 9.7.0.170 (Business Edition)
Hash: b5e1c22
Branch: master
Build date: 2016-01-28 14:11:40-0500

Xamarin.Android
Version: 6.0.1.9 (Business Edition)
Android SDK: /Users/kmullins/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.0

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Xamarin Android Player
Version: 0.1.1
Location: /Applications/Xamarin Android Player.app

Xamarin.Mac
Version: 2.4.1.6 (Business Edition)

Build Information
Release ID: 600003878
Git revision: 7488b4fca4f0095122f08d4781ace8b80541437e
Build date: 2016-01-28 18:19:12-05
Xamarin addins: e6b51d87bef1a3bea1172cfa5dd6007fb6871c6b
Build lane: monodevelop-lion-roslyn-dark-skin-64bit

Operating System
Mac OS X 10.11.3
Darwin Motoko-4.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 6 Alan McGovern 2016-02-18 10:59:15 UTC
I have an alternative way of triggering the same problem:
1 Resize your Xamarin Studio until you can see the desktop and XS.
2) Click on the desktop to make XS lose focus
3) Click on the 'Search' box in the top right of XS. You'll see XS gets focus and the cursor is placed in the search box.

4) Click on the desktop again
5) Now click on any editor in the property panel

Result:
XS gets focus but the cursor is *not* placed inside the control you clicked on.

I think this is another GtkNSView issue so I'm CC'ing Cody in. If the issue i reproed is *not* the same as what you've described do let me know.
Comment 7 Alan McGovern 2016-02-18 10:59:40 UTC
Screencast: http://screencast.com/t/U8zvlOOlb2