Bug 38159 - Navigation fails on all platforms in certain sequence
Summary: Navigation fails on all platforms in certain sequence
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-01-29 01:37 UTC by Adam
Modified: 2016-03-09 21:59 UTC (History)
4 users (show)

Tags: ac Android iOS Windows
Is this bug a regression?: ---
Last known good build:

Sample Reproduction (388.93 KB, application/x-zip-compressed)
2016-01-29 01:37 UTC, Adam
Second Repro (383.97 KB, application/x-zip-compressed)
2016-02-02 08:49 UTC, Adam

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Adam 2016-01-29 01:37:11 UTC
Created attachment 14781 [details]
Sample Reproduction

With a certain navigation sequence and changing of the MainPage, an error is experienced on each platform in a different way.

 - has an overlay of visual elements from Page 2 and 3 together.

 - Goes completely black. Can navigation back though.

 - Crashes with a null reference exception.

 - Doesn't push to final page.

 - As expected, same result as WinRT

On Windows I also noticed that the Modal Stack suddenly had a page in it, when I never added anything to the modal stack.

Sample project attached.

Built with the latest Xamarin Forms 2.0.1 Stable release, running on Windows 10, Visual Studio 2015 Enterprise, latest Xamarin 4 Cycle 6 - SR1.
Comment 1 Adam 2016-02-02 08:49:06 UTC
Created attachment 14844 [details]
Second Repro

Second repro
Comment 2 Adam 2016-02-22 23:13:33 UTC
-pre5 doesn't fix all issues and introduces a new one. Please look at my second repro.
Comment 3 Adam 2016-03-06 00:31:29 UTC
This was fixed in 2.1.0 and can confirm the fix worked.

This can now be marked as resolved.