Bug 38122 - Strange exception vs2015
Summary: Strange exception vs2015
Status: RESOLVED DUPLICATE of bug 39433
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 6.0.99
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2016-01-28 11:01 UTC by Stefan van de Laarschot
Modified: 2016-03-08 03:59 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Exception Error (86.48 KB, image/png)
2016-02-02 12:25 UTC, Stefan van de Laarschot
Same error (156.86 KB, image/jpeg)
2016-02-04 13:57 UTC, ChrisBerlin

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Stefan van de Laarschot 2016-01-28 11:01:47 UTC
I'm Developing an APP wich communicate with BLE devices. everything works fine so fare but when i switch multiple times from an activity i get an undebuggable exception:

01-26 09:06:43.040 I/Timeline( 7341): Timeline: Activity_launch_request id:BLEAPPtime:710885426 Object reference not set to an instance of an object. System.NullReferenceException: Object reference not set to an instance of an object. at Xamarin.VisualStudio.Debugger.AD7DebugExceptionEvent..ctor(Thread thread, String description) in C:\Users\builder\data\lanes\2599\1390b70a\source\XamarinVS\src\Core\VisualStudio\Debugging\MonoTools.Engine\AD7Events.cs:line 433 at Xamarin.VisualStudio.Debugger.ExceptionsAdapter.OnUnhandledException(Object sender, TargetEventArgs args) in C:\Users\builder\data\lanes\2599\1390b70a\source\XamarinVS\src\Core\VisualStudio\Debugging\MonoTools.Engine\ExceptionsAdapter.cs:line 67 at Mono.Debugging.Client.DebuggerSession.OnTargetEvent(TargetEventArgs args) at Mono.Debugging.Soft.SoftDebuggerSession.HandleBreakEventSet(Event[] es, Boolean dequeuing) at Mono.Debugging.Soft.SoftDebuggerSession.HandleEventSet(EventSet es) at Mono.Debugging.Soft.SoftDebuggerSession.EventHandler() Thread finished: #6 The thread '' (0x6) has exited with code 0 (0x0).

I don't know where it came from if i debug every single step is passing until my activity finished at the last code bracket then i get this weird exception.

Does someone has any clue how to debug this? or about this BUG.
Comment 1 Stefan van de Laarschot 2016-02-02 12:25:40 UTC
Created attachment 14845 [details]
Exception Error
Comment 2 ChrisBerlin 2016-02-04 13:57:06 UTC
Created attachment 14895 [details]
Same error

I have the same issue in conjunction with Christ Riesgo's carouselview (horizotal scrollview) when swiping from one to another page) with Xamarin.Forms .

This only occurs in Android ( Xamarin.iOS ( works fine.
Comment 3 Stefan van de Laarschot 2016-02-09 07:30:49 UTC
Its Fixed nothing to do with Xamarin one TIP use Background threading... sometimes when ya have a long running process.
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2016-03-08 03:59:50 UTC
I will mark this as a duplicate of a new bug I have filed to gather all of the information reported by various customers for this issue so far.

*** This bug has been marked as a duplicate of bug 39433 ***