Bug 38082 - frequent UI hang
Summary: frequent UI hang
Status: RESOLVED DUPLICATE of bug 37043
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-01-27 02:55 UTC by Alan McGovern
Modified: 2016-01-27 09:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 37043

Description Alan McGovern 2016-01-27 02:55:30 UTC
I'm getting this hang pretty frequently when debugging in the sim. I don't have a real device attached to my computer:

https://gist.github.com/alanmcgovern/8a6139b3b6676bb6d113

The interesting part is:
"GUI Thread"  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Xamarin.MacDev.IPhoneDevice.AMDeviceCopyValue (intptr,intptr,intptr) <IL 0x0002b, 0xffffffff>
  at Xamarin.MacDev.IPhoneDevice.GetDeviceString (Xamarin.MacDev.CFString) [0x00000] in /Users/alan/Projects/md-addins/external/maciostools/Xamarin.MacDev/Encrypted/IPhoneDevice.cs:135
  at Xamarin.MacDev.IPhoneDevice.TryGetValues () [0x00123] in /Users/alan/Projects/md-addins/external/maciostools/Xamarin.MacDev/Encrypted/IPhoneDevice.cs:280
  at Xamarin.MacDev.IPhoneDevice.get_DeviceType () [0x0000b] in /Users/alan/Projects/md-addins/external/maciostools/Xamarin.MacDev/Encrypted/IPhoneDevice.cs:102
  at MonoDevelop.IPhone.IPhoneProjectFlavor/<GetDeviceTargets>c__Iterator2.MoveNext () [0x000a7] in /Users/alan/Projects/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/Project/IPhoneProject.cs:1075
Comment 1 Lluis Sanchez 2016-01-27 09:18:14 UTC

*** This bug has been marked as a duplicate of bug 37043 ***