Bug 37958 - XS 6 Preview Toggle Line Comments no longer work in XAML/XML files
Summary: XS 6 Preview Toggle Line Comments no longer work in XAML/XML files
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: XML Editor ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C7)
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2016-01-23 23:31 UTC by John Miller [MSFT]
Modified: 2016-05-19 17:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2016-01-23 23:31:06 UTC
**Overview:**

   Toggling line comments does not work anymore in the XS 6.0 preview for XML/XAML files. 

**Steps to Reproduce:**

   Edit a XAML/XML file. 
   Hightlight some text, Edit -> Format -> Toggle Line Comments

**Actual Results:**

   Nothing happens. 

**Expected Results:**

   Should wrap text in <!-- -->

**Build Date & Platform:**

   === Xamarin Studio ===

Version 6.0 (build 3668)
Installation UUID: e01c3049-a2d2-4e0a-aad8-afe6fb627c4d
Runtime:
	Mono 4.3.0 (mono-4.3.1-branch/37d269c) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403002114

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.iOS ===

Version: 9.4.0.0 (Business Edition)
Hash: 7322991
Branch: master
Build date: 2015-12-08 16:20:29-0500

=== Xamarin.Android ===

Version: 6.0.0.34 (Business Edition)
Android SDK: /Users/johnmiller/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.0.109 (Business Edition)

=== Build Information ===

Release ID: 600003668
Git revision: 23e9d5d22133ca5a7c56b26644ab59a4626bccdb
Build date: 2016-01-20 15:12:22-05
Xamarin addins: bca6749910827de4af7eab7a925ff4ccf2bda06a
Build lane: monodevelop-lion-roslyn-dark-skin-64bit

=== Operating System ===

Mac OS X 10.11.2
Comment 1 xamarin-release-manager 2016-02-08 16:49:29 UTC
Fixed in version 6.0.0.3350 (master)

Author: Lluis Sanchez
Commit: 188ecf11f53ada9f4ec13aa0aaeddf571dcfeb3d (mono/monodevelop)
Comment 2 Atin 2016-05-19 17:43:56 UTC
I have checked this issue with latest build of Cycle 7 i.e. XamarinStudio-6.0.0.5165_b44eb696fa41a04696a84d6af7fed9aa494e5580 and now this issue is working fine.

Screencast: http://www.screencast.com/t/M8s6N9Ptm

Hence I am closing this issue.

Thanks!