Bug 37806 - AOT error trying to build for a device in vmware shared folders
Summary: AOT error trying to build for a device in vmware shared folders
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler ()
Version: XI 9.8 (tvOS / C7)
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
Depends on:
Reported: 2016-01-19 19:38 UTC by emailpaveldanilin
Modified: 2016-10-24 18:57 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

The project archive (77 bytes, text/plain)
2016-01-19 19:38 UTC, emailpaveldanilin
The copied build output (81.45 KB, text/plain)
2016-01-20 11:55 UTC, emailpaveldanilin

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description emailpaveldanilin 2016-01-19 19:38:12 UTC
Created attachment 14631 [details]
The project archive

I get "MT3001" error when trying to build my project for a device. But when building for a simulator, all' s fine.
The messages: 
1) /Volumes/VMware Shared Folders/Sharing/project/StudentAttendance/MTOUCH: Error MT3001: Could not AOT the assembly '/Volumes/VMware Shared Folders/Sharing/project/StudentAttendance/obj/iPhone/Release/mtouch-cache/64/Build/System.Data.dll' (MT3001) (StudentAttendance)
2) /Volumes/VMware Shared Folders/Sharing/project/StudentAttendance/MTOUCH: Error MT3001: Could not AOT the assembly '/Volumes/VMware Shared Folders/Sharing/project/StudentAttendance/obj/iPhone/Release/mtouch-cache/64/Build/System.Xml.dll' (MT3001) (StudentAttendance)

Here are the details about the versions of the software I have:
=== Xamarin Studio ===

Version 5.10.1 (build 6)
Installation UUID: 04c47015-0333-4f0f-95bd-c8c35d790921
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.Android ===

Not Installed

=== Xamarin Android Player ===

Not Installed

=== Xamarin.iOS ===

Version: (Starter Edition)
Hash: 7322991
Branch: master
Build date: 2015-12-08 16:20:29-0500

=== Xamarin.Mac ===

Version: (Starter Edition)

=== Build Information ===

Release ID: 510010006
Git revision: 0b60eecdb531933734519c13257d16a780274aab
Build date: 2015-12-04 20:28:20-05
Xamarin addins: 9876fd7c9837977178411ec7375b4352c0a0d6af
Build lane: monodevelop-lion-cycle6-baseline

=== Operating System ===

Mac OS X 10.10.5
Darwin Mac-Admin.local 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64

Thanks in advance.
Comment 1 Zoltan Varga 2016-01-19 22:27:52 UTC
Can't reproduce this. Could you add '-v -v -v' to to Options/ios build/Additional mtouch arguments:, and attach the build output ?
Comment 2 emailpaveldanilin 2016-01-20 11:55:41 UTC
Created attachment 14638 [details]
The copied build output

Like that?
Comment 3 Zoltan Varga 2016-01-20 14:11:06 UTC
Could you try building in a directory which doesn't have spaces in its name (i.e. outside VMWare Shared Folders) ?
Comment 4 emailpaveldanilin 2016-01-20 18:07:39 UTC
That worked! Thanks!
Comment 5 Sebastien Pouliot 2016-01-20 19:45:48 UTC
I wonder if it's the spaces in the path as we do have tests apps with spaces just to make sure this works fine (and they do). So either:

* it comes from a special case the tests does not hit (which could explain why only some, not all, assemblies could not be AOT'ed); or

* it does not like the remote/mounted file system (unclear why it works on some files and not others);
Comment 6 emailpaveldanilin 2016-01-21 19:07:34 UTC
Well, at first, I made a folder on the desktop without spaces and copied my project into it. So, there were no spaces in the path to it too. And everything was built in a normal way.
Then I also created a folder on the desktop called "test folder with spaces" and copied it (project) there. The rebuild worked fine. So, the problem seemed to occur not because of the spaces.
Note: trying to build in shared folders a couple of times in a row brings different errors each time (if that might be important).
Comment 7 Manuel de la Peña [MSFT] 2016-09-15 09:06:30 UTC

Are you still experiencing this issue? Did you manage to solve it?
Comment 8 Alex Soto [MSFT] 2016-10-23 22:33:15 UTC
We have not received the requested information. If you are still 
experiencing this issue please provide all the requested information 
and re-open the bug report. Thanks!
Comment 9 emailpaveldanilin 2016-10-24 18:57:10 UTC
Moving the project from shared flolder into the virtual machine solved the issue.
Sorry for the pause in response.