Bug 37769 - SAP component errors with SQLCipher DLLNotFoundException on Android API 23
Summary: SAP component errors with SQLCipher DLLNotFoundException on Android API 23
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Staging (addons.xamstage.com)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
Depends on:
Reported: 2016-01-18 13:56 UTC by John Miller [MSFT]
Modified: 2016-01-26 16:11 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description John Miller [MSFT] 2016-01-18 13:56:29 UTC

   Using the SAP component on Android API 23 results in an exception thrown.

**Steps to Reproduce:**

   1. Create an Android project
   2. Add SAP Component
   3. Add the following code in the MainActivity.OnCreate method. I placed it in the click handler for the button. 

   new SQLiteConnection("test.db");

**Actual Results:**

[MonoDroid] System.DllNotFoundException: sqlcipher
[MonoDroid]   at (wrapper managed-to-native) SQLite.SQLite3:Open (byte[],intptr&,int,intptr)
[MonoDroid]   at SQLite.SQLiteConnection..ctor (System.String databasePath, SQLiteOpenFlags openFlags, Boolean storeDateTimeAsTicks) [0x0003f] in <filename unknown>:0 
[MonoDroid]   at SQLite.SQLiteConnection..ctor (System.String databasePath, Boolean storeDateTimeAsTicks) [0x00000] in <filename unknown>:0 
[MonoDroid]   at Case246340.MainActivity+<OnCreate>c__AnonStorey0.<>m__0 (System.Object , System.EventArgs ) [0x00037] in /Users/johnmiller/Projects/Case246340/Case246340/MainActivity.cs:29 
[MonoDroid]   at Android.Views.View+IOnClickListenerImplementor.OnClick (Android.Views.View v) [0x0000d] in /Users/builder/data/lanes/2692/50280e42/source/monodroid/src/Mono.Android/platforms/android-19/src/generated/Android.Views.View.cs:1780 
[MonoDroid]   at Android.Views.View+IOnClickListenerInvoker.n_OnClick_Landroid_view_View_ (IntPtr jnienv, IntPtr native__this, IntPtr native_v) [0x00011] in /Users/builder/data/lanes/2692/50280e42/source/monodroid/src/Mono.Android/platforms/android-19/src/generated/Android.Views.View.cs:1745 
[MonoDroid]   at (wrapper dynamic-method) System.Object:1d74a5b0-a0fa-4a27-a1c2-ac4c2db6c829 (intptr,intptr,intptr)

**Expected Results:**

   No Exceptions

**Build Date & Platform:**

   === Xamarin Studio ===

Version 5.10.1 (build 6)
Installation UUID: e01c3049-a2d2-4e0a-aad8-afe6fb627c4d
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Version: 0.30.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: 7322991
Branch: master
Build date: 2015-12-08 16:20:29-0500

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/johnmiller/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: (Business Edition)

=== Xamarin Inspector ===

Hash: 1b526e6
Branch: master
Build date: Tue Nov 17 20:54:30 UTC 2015

=== Build Information ===

Release ID: 510010006
Git revision: 0b60eecdb531933734519c13257d16a780274aab
Build date: 2015-12-04 20:28:20-05
Xamarin addins: 9876fd7c9837977178411ec7375b4352c0a0d6af
Build lane: monodevelop-lion-cycle6-baseline

=== Operating System ===

Mac OS X 10.11.2

**Additional Information:**

   Seems to work on < Api 23.
Comment 1 Bill Holmes 2016-01-19 22:58:11 UTC
I am not able to reproduce this error with the info given.  I do have a later Alpha version

Maybe we fixed something in Xamarin.Android?
Comment 4 Bill Holmes 2016-01-26 16:11:06 UTC

Apologies as we are still not able to reproduce the issue even with the project that you have provided.  Matthew and I have both tried.

You can try to clean up the components and nuget cached files to be sure there is not a corrupt file.


Also be sure to clear the components and packages folders from your project.