Bug 37351 - An error appears when I add a library reference to my project
Summary: An error appears when I add a library reference to my project
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2015-12-31 11:47 UTC by Grigory
Modified: 2016-01-16 10:06 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Grigory 2015-12-31 11:47:15 UTC
I am trying to build an app using XamiAndAr library (XamiAndAr.dll). I downloaded the library and added it to the refernces of my project. When trying to build an Android Package I get the following error:
Description: C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Reason: CRC error: the file being extracted appears to be corrupted. Expected 0x999FC7B3, Actual 0x451A6BBC (XA0000)
What can I do to solve this error?
Comment 1 Jonathan Pryor 2016-01-04 19:52:39 UTC
It sounds like the assembly is corrupted. Can you download it again?

Diagnostic Build output would also be helpful, to at least determine where the error is coming from:

Comment 2 Chetan 2016-01-10 08:17:33 UTC
@Grigory - Please download the dll from: https://xamiandar.codeplex.com/
Please check your Xamarin. Android version and API level. Sample code for using XamiAndAR is here: https://github.com/chetanshetty/XamiAndAR
Let me know if you face any problems.
Comment 3 Grigory 2016-01-10 20:53:45 UTC
Good evening everyone! Thanks for your answers!
Chetan, I downloaded the library and the sample code from your website and github, but the same mistake persisted. The minimum API Level set by Xamarin Studio is 15 (Xamarin.Android v.4.0.3), the project is automatically upgraded when I initially loaded it. May the problem occur because of the downloaded library was built for API Level 12 (Xamarin.Android v.3.1)?
Thanks for your answer in advance!
Comment 4 Chetan 2016-01-11 04:01:41 UTC
Hi Grigory

Downloaded library is built in API Level 12 (Xamarin.Android v.3.1) as mentioned in the website refer - https://xamiandar.codeplex.com/ I will rebuild and upgrade soon. Meanwhile you try in API Level 12 (Xamarin.Android v.3.1) and let me know. Because for me its working.
Comment 5 Grigory 2016-01-11 21:59:07 UTC
Hi Chetan
I installed Xamarin Studio from the official site (current version is 5.10) and downloaded API 12 using SDK Manager. Still Xamarin Studio says it supports v.4.0.3 (API 15) and newer versions. Do you have an installer for v.3.1 (maybe an earlier version of Xamarin Studio is required)?
Thanks for your answer in advance!
Comment 6 Chetan 2016-01-12 08:08:59 UTC
Hey can u try in Xamarin plugin for Visual Studio ? Are u comfortable with it?
Let me know, otherwise I provide you one which works for you.
Comment 7 Grigory 2016-01-12 16:31:27 UTC
Yes, I tried in Visual Studio but did not succeed. I'll be grateful if you could provide a Xamarin plugin which works.
Comment 8 Grigory 2016-01-16 10:06:30 UTC
The problem was solved thanks to Chetan!