Bug 37151 - Android AAR binding with native .SO libraries
Summary: Android AAR binding with native .SO libraries
Alias: None
Product: Components
Classification: Xamarin
Component: Generation ()
Version: N/A
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
Depends on:
Reported: 2015-12-18 18:01 UTC by Jesus Garcia
Modified: 2017-02-20 08:37 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jesus Garcia 2015-12-18 18:01:17 UTC
Hi, I'm currently binding the AirWatch library, and after many issues I was finally able to bind everything correctly, but now when using/testing the library, I encounter issues on some of the .so files that are included in the AAR files.

The java (aar) method is: 

    public synchronized native int awFipsModeSet(int var1);

which is included through an .so file.  

But when you run the bindings project it throws an exception saying it can't find the implementation. Maybe the tool is not adding the .SO files included in the AAR?

No implementation found for int com.airwatch.crypto.openssl.OpenSSLWrapper.awFipsModeSet(int) (tried Java_com_airwatch_crypto_openssl_OpenSSLWrapper_awFipsModeSet and Java_com_airwatch_crypto_openssl_OpenSSLWrapper_awFipsModeSet__I)
Comment 1 Sergio 2016-07-18 14:30:32 UTC
Were you able to fix the issue? I have exactly the same on Mac and I am not able to get the Android SDK v.16.02 or 15.06 running. Always the same issue running the example provided within the SDK. Please help asap.
Comment 2 Arun 2017-02-20 08:03:46 UTC
did you fix this issue? I am using AirWatch SDK and getting the same issue, when i running the sample code provided within the SDK. please help...
Comment 3 Arun 2017-02-20 08:06:55 UTC
Hi Sergio,
    did you fix this issue?
Comment 4 Sergio 2017-02-20 08:32:50 UTC
Hi Arun,

We were not able to make the AWFramework to work, the AirWatch team is aware of this and it was confirmed the examples provided with the code do not worked. 

We ended up just using the AirWatch SDK for a really basic functionality, as retrieve the username from the AirWatch console, nothing more complex rather than that.

After my short experience working with the AirWatch SDK for Android/iOS I will recommend to avoid them if possible. 

Comment 5 Arun 2017-02-20 08:36:06 UTC
Hi Sergio,
          Thanks for your help and reply..
Comment 6 Sergio 2017-02-20 08:37:32 UTC
Hi Arun,

Apologies for not being more helpful. 

Good luck with it.