Bug 36446 - Xamarin Bonjour service is not being installed with VS 2015 Update 1 custom Xamarin install option
Summary: Xamarin Bonjour service is not being installed with VS 2015 Update 1 custom X...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
: 40731 ()
Depends on:
Reported: 2015-12-01 21:34 UTC by Ben Beckley
Modified: 2016-12-22 23:14 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

from custom install (276.21 KB, application/zip)
2015-12-01 21:34 UTC, Ben Beckley

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Comment 1 Ben Beckley 2016-01-19 18:32:02 UTC
This issue has since been fixed.
Comment 2 Kate Johnson 2016-04-27 13:05:48 UTC
If it's been fixed why am I having this problem right now?
Comment 3 Ben Beckley 2016-04-27 15:55:56 UTC
Hello Kate,

Could you please provide some information so that we can look into it?

- The installer you are using.
- The operating system you are using.
- If you already have Xamarin installed.
- A log file from your %temp% folder that starts with "dd_XamarinCleaner"
- The Visual Studio setup log

Thank you
Comment 4 Kate Johnson 2016-04-28 01:32:56 UTC
- The installer came from the xamarin site: vstoolsforxamarin.exe, visual studio installer.
- Windows 7 professional with service pack 1
- I did not have xamarin already installed or visual stuido 2015
- Log file contents:
27/04/2016 9:52:15 PM - Getting ProductCode for UpgradeCode: {08C9B12D-289F-44C8-9A88-DC990510EC89}
27/04/2016 9:52:15 PM - ERROR: MsiEnumRelatedProducts returned: 259
27/04/2016 9:52:15 PM - ProductCode not found!
- Can't find Visual Studio setup log.

Comment 5 Kate Johnson 2016-05-04 12:56:29 UTC
So, still no solution Ben?

Guess I'm going back to Android studio.

How depressing.
Comment 6 Ben Beckley 2016-05-04 22:45:00 UTC
Hello Kate,

I haven't been able to reproduce this issue using Windows 7 with SP1 7601, and the vstoolsforxamarin installer from the Xamarin site. Additionally, I have brought this up with the Visual Studio Extension team and they have looked into the issue as well. I have a couple questions that may help us get a reproduction, or at least find a temporary workaround for you.

- Do you happen to have any other Bonjour services installed - such as Apple Bonjour services?

- What is it that you are doing where not having the Xamarin Bonjour services blocks you?
Comment 7 Ben Beckley 2016-05-05 19:50:06 UTC
*** Bug 40731 has been marked as a duplicate of this bug. ***
Comment 8 Kate Johnson 2016-05-11 13:10:13 UTC
Hi Ben,

apologies for the delay.

I used to have itunes installed on this laptop, it was removed long before I tried to install VS with Xamarin.

I tried to rectify the problem myself by installing the Bonjour print program and then reinstalling VS but still had the same issue.

It's during the installation where I get the error, when trying to install the part to do with android development.

I have a screen shot of the error.. not sure where to upload it.
Comment 9 Jose Gallardo 2016-12-22 23:14:33 UTC
As we've added several improvements to our installer since the bug was reported, I'm resolving it tentatively as Fixed.
That said, if you're still facing this issue with current bits, please feel free to reopen the bug.