Bug 36186 - Jenkins build script that previously worked now fails with X4/C6.
Summary: Jenkins build script that previously worked now fails with X4/C6.
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 9.2
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: C6SR1
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2015-11-23 19:19 UTC by Jon Goldberger [MSFT]
Modified: 2015-11-24 16:51 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jon Goldberger [MSFT] 2015-11-23 19:19:48 UTC
## Description (from customer)
Jenkins build script that previously worked now fails with X4/C6. It creates an IPA that contains iTunes Artwork and Metadata even though not selected in project options, and embedded.profile required to upload to the AppStore is missing.

# Steps to reproduce

Test project not provided, nor do I have Jenkins, so I do not have steps to reproduce. 

# Expected behavior
IPA will build with embedded.profile in IPA and without iTunes Artwork and Metadata

# Actual behavior
embedded.profile is missing and iTunes Artwork and Metadata are included

# Supplemental info (logs, images, videos)
It was suggested that it may be this bug: bug #29180, but that is supposedly fixed in C5SR1. 

# Test environment (full version information)
=== Xamarin Studio ===

Version 5.10 (build 871)
Installation UUID: 7cbcce91-7a74-446d-840f-4e77c77fa30a
Mono 4.2.1 (explicit/6dd2d0d)
GTK+ 2.24.23 (Raleigh theme)

Package version: 402010102

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.1.1 (9081)
Build 7B1005

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: 3c0ec35
Branch: master
Build date: 2015-11-12 13:05:39-0500

=== Xamarin.Android ===

Version: (Enterprise Edition)
Android SDK: /Users/dross/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
2.3 (API level 10)
4.0.3 (API level 15)
4.4 (API level 19)
5.0 (API level 21)
5.1 (API level 22)
6.0 (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: (Starter Edition)

=== Build Information ===

Release ID: 510000871
Git revision: 4e9c5abb5ffdae12ba02ac49da83f8b2011dbb88
Build date: 2015-11-12 06:02:54-05
Xamarin addins: 55007ed0e56436f385d8e26394a45be563abc7e8
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.1
Darwin david.local 15.0.0 Darwin Kernel Version 15.0.0
Sat Sep 19 15:53:46 PDT 2015
root:xnu-3247.10.11~1/RELEASE_X86_64 x86_64
Comment 3 Jon Goldberger [MSFT] 2015-11-23 19:22:46 UTC
Build script and build output attached as private attachments.
Comment 6 Jeffrey Stedfast 2015-11-24 14:20:20 UTC
Change the Jenkins script to use this xbuild command:

/usr/local/bin/xbuild /p:Configuration=Release /p:Platform=iPhone /p:BuildIpa=true /p:IpaIncludeArtwork=false $PROJECT_PATH