Bug 35453 - Gesture Recognisers ignore on all but the first gesture
Summary: Gesture Recognisers ignore on all but the first gesture
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-11-02 07:34 UTC by Paul Johnson
Modified: 2016-04-13 19:12 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Page showing the issue (7.67 KB, application/octet-stream)
2015-11-02 07:34 UTC, Paul Johnson

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Paul Johnson 2015-11-02 07:34:58 UTC
Created attachment 13605 [details]
Page showing the issue

I have 3 gesture recognisers set to trigger on the three images within the relative layouts.

The first recogniser will always fire - the others don't. If I remove the first recogniser, the other two still don't fire. On iOS and Windows Phone, they always hit the event.

I have tried the recogniser on the relative layouts (in case the layout was in front of the image), but the recognisers still fail.

=== Xamarin Studio ===

Version 5.10 (build 811)
Installation UUID: 728e2a5d-c6a2-4d84-a931-ee64cb78694c
	Mono 4.2.1 (explicit/804ddbc)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010060

=== Xamarin.Profiler ===

Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: b5396c2
Branch: master
Build date: 2015-09-30 15:22:15-0400

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/PFJ/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.7
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: (Starter Edition)

=== Build Information ===

Release ID: 510000811
Git revision: 34cd31ea72536afab530c14d9220b286075e83cd
Build date: 2015-09-30 10:40:37-04
Xamarin addins: 8e6fccfc0c19a7e0b7b11be925f09751d827eb5c
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.1
Darwin Pauls-MacBook-Pro.local 15.0.0 Darwin Kernel Version 15.0.0
    Sat Sep 19 15:53:46 PDT 2015
    root:xnu-3247.10.11~1/RELEASE_X86_64 x86_64
Comment 1 Paul Johnson 2015-11-02 09:42:02 UTC
The current alpha version shows this problem on Android, iOS and WinPhone
Comment 2 Paul Johnson 2015-11-03 11:11:15 UTC
I've modified the definition now to use a Command within the setup of the TapGestureRecognizer. Makes no difference
Comment 4 Paul Johnson 2015-11-03 19:13:02 UTC
The issue seems to be down to the RelativeLayout. If I don't set the Height property, the tap recogniser is ignored. If I do set the property, it works.
Comment 5 Stephane Delcroix 2016-01-20 16:42:22 UTC
Hi Paul,

I'd like to reproduce your issue, but your project takes ages to download whatever content it needs.

It would help us a lot if you could create the simplest possible project triggering that issue.

Thanks for your help !

The XF team
Comment 6 Paul Johnson 2016-01-20 17:09:36 UTC
I'll create a smaller example for you
Comment 7 Jason Smith [MSFT] 2016-04-13 19:12:59 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team